Bug #2444

csv download of code list has incomplete header

Added by Tilman Brock-Hesse about 5 years ago. Updated over 4 years ago.

Status:ClosedStart date:21 May 2015
Priority:HighDue date:
Assignee:Emanuela Epure% Done:

0%

Category:-
Target version:-

Description

When downloading a codelist as csv the header line is missing the first 5 field names.

How to reproduce:

  1. Open the page http://inspire.ec.europa.eu/codelist/AquiferTypeValue/ (or any other codelist page)
  2. Click on "Download as CSV"
  3. Download the CSV file AquiferTypeValue ( http://inspire.ec.europa.eu/codelist/AquiferTypeValue/AquiferTypeValue.en.csv )
  4. Open file, look at first line

Expected result:

All fields are correctly named, that is the first line reads something like

"ID|Language|Label|Description|Definition|Governance level ID|Governance level Label|Codelist ID|Codelist label|Reference Source|Reference Link|Status ID|Status label|Parent ID|Successor ID|Predecessor ID"

Actual result:

First line reads "|||||Governance level ID|Governance level Label|Codelist ID|Codelist label|Reference Source|Reference Link|Status ID|Status label|Parent ID|Successor ID|Predecessor ID" with the first 5 fields empty.

The first fields are empty also when downloading the german version, the other fields are correctly translated. I have not checked other languages.

History

#1 Updated by Tilman Brock-Hesse about 5 years ago

Just to clarify: the values are all correctly included in the csv, only the header line is missing the field names.

#2 Updated by Michael Lutz about 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Emanuela Epure

Daniele, Emanuela,

could you please look into this?

Thanks, Michael

#3 Updated by Tilman Brock-Hesse about 5 years ago

Is there a roadmap on when this will be fixed?

#4 Updated by Tilman Brock-Hesse about 5 years ago

Tilman Brock-Hesse schrieb:

Is there a roadmap on when this will be fixed?

Seems to be fixed in sandbox: http://inspire-regadmin.jrc.ec.europa.eu/service-sandbox/codelist/GeometryMethodValue/ .

#5 Updated by Daniele Francioli about 5 years ago

Sorry for the delay in the answer. We are working on it. We will inform you when this problem will be solved.

#6 Updated by Daniele Francioli about 5 years ago

  • Status changed from Assigned to Work in progress

#7 Updated by Daniele Francioli almost 5 years ago

  • Status changed from Work in progress to Resolved

#8 Updated by Michael Lutz over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF