Support #2664

CY: Connecting the National Discovery Service to the INSPIRE Geoportal

Added by Angelo Quaglia over 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:22 Jan 2016
Priority:NormalDue date:
Assignee:Angelo Quaglia% Done:

0%

Category:Discovery Service Register
Target version:-
Submitting Organisation:CY Knowledge-Base relevant?:
Proactive:No Keyword #1:
Country:CY - Cyprus Keyword #2:
Originating UI: Keyword #3:

Description

In order to test the connection of the National Discovery Service to the INSPIRE Geoportal we would need the URL of the endpoint of your OGC CSW 2.0.2 service.

The service needs to be exposed on HTTP default ports, i.e. 80 or 443.

 

 

Screen_Shot.jpg (547 KB) Andreas Hadjiraftis, 17 May 2016 08:44 am

MR_Indicators_DLS_INSPIRE_20160609.xls (201 KB) Andreas Hadjiraftis, 10 Jun 2016 09:05 am

Screen_Shot.jpg (290 KB) Andreas Hadjiraftis, 19 Oct 2016 12:06 pm

1678
1826

Related issues

Related to Geoportal Helpdesk - Support #2868: CY: Cannot locate Cyprus Inspire Web Site Closed 19 Oct 2016

History

#1 Updated by Andreas Hadjiraftis over 4 years ago

The Geoportal of Cyprus can be accessed at: http://www.geoportal.gov.cy From the front page menu, a user can select INSPIRE from the middle, and then the Geocatalogue opens at the following address: http://213.136.80.55:58086/geonetwork/srv/gre/catalog.search#/search?fast=index&_content_type=json&sortBy=relevance&from=1&to=10 Bothe the front page and the geocatalogue work in English and Greek. From there, a total of 136 data sources can be accessed. This number is continuously growing as we are adding services as they become available from the stakeholders. Please note that we have locked downloading access for a few days until each stakeholder chacks and validates it's data, and until they decide which data will be given full downloading access. It is expected that very soon we will be ready to release all services. An example is EBM Administrative Units - Residence of Authority at: http://213.136.80.55:38080/deegree-webservices-3.3.14/services/dls-wfs This service can be directly accessed and downloaded in GML. Please let me know if the above answers your question.

#2 Updated by Andreas Hadjiraftis over 4 years ago

Please confirm.

#3 Updated by Angelo Quaglia over 4 years ago

Dear Andreas,

Many thanks.

 

We assume that the OGC CSW 2.0.2 endpoint is:

http://213.136.80.55:58086/geonetwork/srv/gre/csw?service=CSW&version=2.0.2&request=GetCapabilities

Please confirm.

 

Please note that as stated above, the INSPIRE Geoportal will need the service to be exposed on HTTP default ports, i.e. 80 or 443.

On external servers non-default HTTP ports like 58086 are kept closed as a standard security measure.

#4 Updated by Angelo Quaglia over 4 years ago

Dear Andreas,

the results of the preliminary tests are avilable here:

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-0406507e-c8d5-11e5-97c9-001999e13b4e_20160201-121452/services/1/PullResults/

The main issue is that the metadata documents describe only services. There is not dataset described.

 

#5 Updated by Andreas Hadjiraftis over 4 years ago

Thanks for the very valuable comments. The Geoportal we have published is continuously being updated/upgraded. Very soon we will be ready to provide full access (download and WFS) to all available data sets. In the meantime we are in the process of implementing a more sophisticated platform (DLS Platform)which is based on the servers and the databases of the Department of Lands and Surveys. A series of datasets are currently under processing and internal validation. Very soon we will be able to provide access to you for further validation and consultation. In the meantime, we will do our best to enhance as much as possible the current platform.

#6 Updated by Andreas Hadjiraftis about 4 years ago

Please note that a total of 142 services are currently available through our geoportal. This number continues to grow as services become available. All services now are available for downloading and direct accessing. Very shortly, we will be able also to publish a high resolution (50cm) mosaic of new ortho photos. Additionally, DLS portal will be published by the end of next month, offering additional functionality and services. Our 3-year country report (2013-2015 inclusive) and Monitoring Report (for 2015) depict all progress done.

#7 Updated by Angelo Quaglia about 4 years ago

Dear Andreas,

Many thanks for the update.

I would appreciate if you could also give an update regarding my comment above:

Please note that as stated above, the INSPIRE Geoportal will need the service to be exposed on HTTP default ports, i.e. 80 or 443.

On external servers non-default HTTP ports like 58086 are kept closed as a standard security measure.

 

Have you made available Cyprus National Discovery Service via an HTTP default port?

If you have, what is the new CSW endpoint?

With that you can then follow the instructions available here in order to connect it to the INSPIRE Geoportal:

https://ies-svn.jrc.ec.europa.eu/projects/mig-inspire/wiki/DiscoveryServiceRegister

 

Best regards,

Angelo

#8 Updated by Andreas Hadjiraftis about 4 years ago

Dear Angelo, Our technical staff confirmed that this requirment has already been implemented. From www.geoportal.gov.cy you can access our geocatalogue (http://inspire.cyprus.moi.gov.cy/) at the new port as instructed. Could you please re-confirm this from your side? Regards, Andreas

#9 Updated by Angelo Quaglia about 4 years ago

Dear Andreas,

yes it works, thank you.

However, there is another even more important previous comment of mine waiting for your kind input:

"The main issue is that the metadata documents describe only services. There is not dataset described."

I have just run the harvesting against the new endpoint and I can still only find metadata describing services:

This is actually infringing the legal requirement of the INSPIRE Metadata Regulation.

When are you going to add the metadata documents describing the datasets served by the services?

 

Best regards,

Angelo

#10 Updated by Angelo Quaglia about 4 years ago

  • Status changed from Assigned to Feedback

In addition, all 141 metadata documents fail the validation against the xml schema.

I strongly recommend you use the INSPIRE Geoportal Validator (http://inspire-geoportal.ec.europa.eu/validator2/) to ensure your metadata documents are valid.

 

Best regards,

Angelo

#11 Updated by Andreas Hadjiraftis about 4 years ago

Dear Angelo, Thank you for your very valuable comments. As I have already described (this is depicted in our 3-year country report), we are now in an intermediate process of INSPIRE implementation. We have managed to collect and publish 141 datasets in a very short period of time, and we have made them available for viewing, downloading, and direct accessing. Most datasets were derived from our Land Information System which is in operation for almost 20 years, and from various databases of other departments and organisations. We know that there is still significant work to be done, and for this reason we need your help. The current geocatalogue will serve for an intermediate period until the DLS-portal will be completed. DLS-Portal, which is currently under development by the Department of Lands and Surveys, is almost completed. It is expected to be published by the end of next month. This is also explained in detail in our counrty report. The idea was that the current geoportal, which has already been published, to be used as a starting point to collect and distribute INSPIRE datasets ('as is')and then use them to feed DLS Portal which will be the final destination. In DLS Portal, all testing, validation, metadata creation etc are expected to be fully compatible to INSPIRE directive. It is noted once again that Cyprus had a significant delay (almost 3 years) in implementing the directive, mainly due to the very serious financial crisis of the last years. I confirm that we have made a lot of progress, and that soon we will be able to fully comply with the directive. We are looking forward to cooperate with you and have positive results the soonest possible. Is it possible/advisable at this stage to connect the current geoportal to the European Geoportal, or should we wait for DLS-Portal to be completed first? Regards, Andreas

#12 Updated by Angelo Quaglia about 4 years ago

  • Submitting Organisation set to CY

Dear Andrius,

many thanks for the clear explanation.

 

Many other Member States have been following an incremental approach and from time to time they also need to change the endpoint of their National Discovery service.

It is true, though, that they started with publishing dataset metadata and added the services later.

On the other hand, there is no problem with that and you can certainly already register your current endpoint and connect it to the INSPIRE Geoportal.

There are a few steps to follow that are described here: https://ies-svn.jrc.ec.europa.eu/projects/mig-inspire/wiki/DiscoveryServiceRegister

If you do that, you will get familiar with the registration procedure, the harvesting parameters and options (harvesting frequency, optional filter, degree of parallelism etc.) you need to specify and how to access the validation reports.

So, by the time when the final Discovery Service becomes available, the effort will be minimal.

Best regards,

Angelo

 

#13 Updated by Andreas Hadjiraftis about 4 years ago

Dear Angelo, Thank you once again for your valuable advice. We will try to follow your recommendations and proceed with registering our Geoportal. Regards, Andreas Hadjiraftis

#14 Updated by Andreas Hadjiraftis about 4 years ago

Dear Angelo, I tried to follow the instructions and I logged in INSPIRE Service Register successfully. However on the menu there is no selection option for New Submission. How should I proceed? Please see attached screen shot. Andreas Hadjiraftis

#15 Updated by Andreas Hadjiraftis about 4 years ago

REMINDER

Dear Angelo,

I would be very obliged if I could have your response on my previous message.

 

Regards,

Andreas Hadjiraftis

#16 Updated by Angelo Quaglia about 4 years ago

Dear Andrius,

I am sorry, but I did not receive the authorization.

Your account needs to be given write access.

 

"Requests for authorizing additional users for a country (up to three users can be authorized for each Country) can be sent by the INSPIRE National INSPIRE Contact Point to the JRC geoportal team

"

Has that request been sent?

#17 Updated by Angelo Quaglia about 4 years ago

Oh, I see it is actually you.

Has your ECAS account been registered with the following email address?

ahadjiraftis@dls.moi.gov.cy

#18 Updated by Angelo Quaglia about 4 years ago

I have given write access to the ECAS account associated with the email address ahadjiraftis@dls.moi.gov.cy 

 

#19 Updated by Angelo Quaglia about 4 years ago

Please feel free to register.

#20 Updated by Andreas Hadjiraftis about 4 years ago

I will try again.

Thanks.

Andreas

#21 Updated by Andreas Hadjiraftis about 4 years ago

Dear Angelo,

 

I have completed the whole process as instructed.

 

Could you please confirm it?

 

Regards,

 

Andreas

#22 Updated by Angelo Quaglia about 4 years ago

  • Status changed from Feedback to Resolved

Dear Andreas,

I confirm you that you have successfully completed the registration process of the National Discovery Service for Cyprus.

Many thanks and best regards,

Angelo

#23 Updated by Andreas Hadjiraftis about 4 years ago

Dear Angelo,

 

Thank you very much for the confirmation.

Furthermore, I would like to inform you that the new Internet Platform of the Department of Lands and Surveys of Cyprus, the “DLS PORTAL” is expected to go live, within the 3rd week of June 2016.

The DLS PORTAL, which as I already described is the second major project for our INSPIRE Geoportal implementation, includes new transformed data / services according to INSPIRE Directive.

For this reason, we would kindly like to have your Static IP address through which you access the Internet, in order for us to proceed with all the necessary preparations (open access for you before going live) that will help you proceed with the “Compliance Testing” of our new Portal in the coming weeks.  Information regarding available Data Themes, URL’s, etc. will follow in a separate email.

Regards,

 

Andreas

#24 Updated by Angelo Quaglia about 4 years ago

Dear Andrea,

That's great, I am looking forward to that.

I assume that the new portal will also make available the metadata of all Spatial Data Sets on which the Network Services operate.

Here are the IP addresses I would need to be authorized:

INSPIRE Geoportal production 139.191.1.236
JRC Proxy 139.191.247.0 to 139.191.247.31
   

The JRC Proxy is required to run tests that cannot be exceuted on the Production environment.

 

Best regards,

Angelo

#25 Updated by Andreas Hadjiraftis about 4 years ago

Dear Angelo,

 

Thank you for the immediate response.

I will keep you informed regerding further developments and actions.

 

Regards,

 

Andreas

#26 Updated by Andreas Hadjiraftis about 4 years ago

Dear Angelo,

 

In continuation to our previous correspondence, I would like to inform you that you may now proceed with all the required “compliance” tests on our new DLS-INSPIRE GeoPortal. This resides on the new Internet Platform of the Department of Lands and Surveys of Cyprus, the “DLS PORTAL”.  The platform will be open to the public by Monday 13th June 2016. 

 

The new INSPIRE GeoPortal of Cyprus includes transformed data / services according to INSPIRE Directive.  The address for the DLS Portal can be found at http://portal.dls.moi.gov.cy/el-gr/homepage  and for the INSPIRE GeoPortal within, at  http://eservices.dls.moi.gov.cy/#/national/inspiregeoportalmapviewer

 

Please do note that for every data theme, we have implemented a metadata record for data, a metadata record for view service and a metadata record for download service.

 

For your help, attached please find the new Monitoring Report which includes all the relevant data and information, as well as the requested URL’s.

 

Thanking you for your prompt action on the matter.

Regards,

Andreas Hadjiraftis

#27 Updated by Angelo Quaglia about 4 years ago

Dear Andreas,

many thanks.

I have opened the urls you gave me. The sites look very nice.

For performing the test, I actually need the endpoint of the CSW service that serves the metadata records, e.g.

http://37.97.143.178/geocatalog/srv/eng/csw?service=CSW&request=GetCapabilities

or https://msdi.data.gov.mt/geonetwork/srv/eng/csw?SERVICE=CSW&REQUEST=GetCapabilities

 

#28 Updated by Andreas Hadjiraftis about 4 years ago

Dear Angelo,

 

Please find below the required info:

 

http://eservices.dls.moi.gov.cy/geoportal_inspire/csw?Request=GetCapabilities&Service=CSW&Version=2.0.2

 

Regards,

 

Andreas

#29 Updated by Angelo Quaglia about 4 years ago

Dear Andreas,

many thanks for the endpoint.

Following the activation of additional cyber-security measures, we are having some temporary difficulties accessing external sites from our internal systems.

However, I have been able to test all of your metadata resources simply by validating the following URL with the INSPIRE Geoportal Validator at http://inspire-geoportal.ec.europa.eu/validator2/:

http://eservices.dls.moi.gov.cy/geoportal_inspire/csw?request=GetRecords&maxRecords=1000&outputSchema=http://www.isotc211.org/2005/gmd&constraint_language_version=1.1.0&type=service&version=2.0.2&startPosition=1&typeNames=gmd:MD_Metadata&service=CSW&constraintLanguage=FILTER&namespace=xmlns(csw&elementSetName=full&resultType=results&outputFormat=application/xml

The validation report is available here:

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-3600a784-313c-11e6-bc3d-52540023a883_20160613-095535/

 

The report shows only resources with validation issues.

All datasets are fine except two.

The Network Services share the issue concerning the service MetadataURL which seems not to point to service metadata.

There are also issue with the URLs pointing to metadata of datasets portrayed in View Service Layers and made available by Download Services.

Please let me know if you need assistance reading the report.

Feel free to repeat the validation as often as you require using the on-line validator.

 

Best regards,

Angelo

#30 Updated by Andreas Hadjiraftis about 4 years ago

Dear Angelo,

 

Thank you for the valuable report and information given.

 

The report contents are currently under study by our technical team.

 

We will respond back to you the soonest possible.

 

Regards,

 

Andreas Hadjiraftis

#31 Updated by Andreas Hadjiraftis about 4 years ago

Dear Angelo,

 

T-Mapy (our INSPIRE Contractor for the DLS PORTAL in the Czech Republic)  is performing all required tests and has proceeded with correcting most of the remarks received.  Since they have some highly technical and specific queries, T-Mapy has asked us if you can speak with them directly (by email and then by telconf if necessary), in order to speed up the process and tackle all issues at once.

 

T-Mapy person:

Martin Maly

martin.maly@tmapy.cz

 

In any case I have to be informed about all matters and actions.

 

Please confirm.

 

Regards,

Andreas

#32 Updated by Angelo Quaglia about 4 years ago

Dear Andreas,

that's excellent news.

Yes, sure, they can contact me, any time.

I think the best thing would be to interact using this tool(*), for which they would need an ECAS account ( https://webgate.ec.europa.eu/cas/eim/external/register.cgi ).

Otherwise, I would need to copy and paste from emails.

It would also be the best way for you to keep up-to-date with the issues.

Of course, they are welcome to contact me by phone, when necessary.

Best regards,

Angelo

 

(*)

Communication
In order to streamline and keep better track of the communication between the geoportal team and the contact points for the discovery services in the Member States, we will start using a dedicated project on the MIG collaboration space (including a wiki, issue tracker and news section) as the main communication channel instead of e-mail. The project will be private and will be open to all registered discovery service contact points as well as interested INSPIRE NCPs or MIG representatives.

Getting access
In order to get access to this Geoportal project on the MIG collaboration space, please send an e-mail to inspire-geoportal@jrc.ec.europa.eu (or reply to this mail). If you have never used the MIG collaboration space for other projects, please also send us your ECAS login.

 

#33 Updated by Andreas Hadjiraftis about 4 years ago

Dear Angelo,

 

Thanks for your response.

I have forwarded your message to our technical staff.

They will contact you ASAP.

 

In any case I need to be kept informed about the progress and details of actions taken.

 

Regards,

Andreas

#34 Updated by Angelo Quaglia almost 4 years ago

  • Category set to Discovery Service Register

#35 Updated by Angelo Quaglia almost 4 years ago

  • Status changed from Resolved to Closed

#36 Updated by Andreas Hadjiraftis almost 4 years ago

Dear Angelo,

 

Could you please clarify what exactly needs to be done in order to register the new endpoint:

 

https://ies-svn.jrc.ec.europa.eu/login?back_url=https%3A%2F%2Fies-svn.jrc.ec.europa.eu%2Fissues%2F2664

 

Regards,

 

Andreas Hadjiraftis

Ag. Chief Lands Officer (Cartography/Geodesy/Hydrography)

Department of Lands and Surveys, Ministry of Interior,

President of Permanent Committee for the Standardisation of Geographical Names of Cyprus

Nicosia, Cyprus

_______________________________________________________________

Tel: +35722804813 | Fax: +35722804874 | email: ahadjiraftis@dls.moi.gov.cy

Website: www.moi.gov.cy/dls

 

 

From: Neoclis Neocleous [mailto:nneocleous@dls.moi.gov.cy]
Sent: Thursday, September 15, 2016 9:19 AM
To: Andreas Hadjiraftis
Cc: Andreas Sokratous
Subject: INSPIRE UPDATE - DLS PORTAL

 

Dear Andreas,

 

Below is the last communication NETU / TMAPPY had with Angelo from JRC:

 

Dear Antonis, 

my personal opinion is that you have done and are doing an awesome job.

It is better to keep very well distinct the following three aspects because they have different deadlines in INSPIRE:

1) Metadata of Spatial Data Set, Series and Services

I see you have created the metadata for Spatial Data Sets that are referenced by the Network Services, and for those metadata no issue is reported by the Validator(*).

That is great.

Even for just this reason I would urge your client to register the new CSW endpoint because it is about the very first INSPIRE deadline that expired long ago.

The metadata for the Spatial Data Services are almost perfect except for a warning in the following two metadata:

{EC8B5B08-6559-486E-9A4D-8D4DE4757BA3} 

<srv:operatesOn uuidref="{15352569-03EF-4CA9-8B07-B5E574D96005}" />

<srv:operatesOn uuidref="{358FA4BB-BAA6-4D84-88BD-2AC0690EF0A9}" xlink:href="http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7BE6AEA1A1-21F4-4D0E-9842-3D965D073C1C%7D" />

<srv:operatesOn xlink:href="http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7BEBB2176C-CFBC-4F44-A3BC-ECD32FAD84C9%7D" />

 

{52B81654-4FBC-4639-96E8-07DDD5171198}

<srv:operatesOn uuidref="http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id={D4848C14-6000-4269-ABD3-0760984C435E}" xlink:href="{9706A340-D7DA-47DE-9EEB-8DFE187A1A49}" />

<srv:operatesOn uuidref="{38CB0FF4-2AB9-4647-800F-BF0A7DB5BB26}" xlink:href="http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7BB289D9FD-672D-401E-8F33-E9DC8A836648%7D" />

 

The Geoportal is not happy about the operatesOn elements without the xlink:href attribute.

 

2) Network Services and, among these, (Discovery Service, View Services and Download Services)

You are doing an amazing work also with View and Download Services.

Datasets are correctly linked to View and Download Services and Download Services serve what looks like INSPIRE GML.

I really would not worry about response times for now as long as the requests eventually work and they do.

 

3) Data specifications and interoperability of Spatial Data Sets and Services

You are already beyond the current abilities of the validator in terms of what is checked. More will come.

I am not in a position to give an opinion on how compliant your INSPIRE GML is, for the time being, but this is not a reason to delay the registration of the new CSW endpoint.

The next step will be the validation of some of the downloaded features against the INSPIRE schemas.

It the validator already were doing that, it would have reported the following validation error:

http://weba.dls.moi.gov.cy/arcgis/rest/services/INSPIRE/CP_CadastralParcels/MapServer/exts/InspireFeatureDownload/service?request=GetFeature&Language=eng&CRS=http://www.opengis.net/def/crs/EPSG/0/3048&DataSetIdNamespace=http://moi.gov.cy/&service=WFS&STOREDQUERY_ID=http://inspire.ec.europa.eu/operation/download/GetSpatialDataSet&version=2.0.0&DataSetIdCode=%7BC9B8147A-38B4-4267-8D72-B41BBCA19714%7D

From what I can see (and this is, again, my personal, though technical, opinion), you are very well covered as far as the first two points are concerned and for which the respective deadlines have already expired.

Please ask your client to register the new CSW endpoint as soon as possible so that the new resources can appear on the INSPIRE Geoportal.

Many thanks for your work and best regards,

Angelo

 

(*)DISCLAIMER: The INSPIRE Geoportal Validation Service is used in the context of the INSPIRE Geoportal to perform validation of the metadata of resources discovered through the Member State Discovery Services. It is provided as is and it is not to be considered a full INSPIRE compliance test. While we have tried to ensure compliance with the INSPIRE Regulations and the relevant Technical Guidance documents we do recognise that there may still be issues that will need to be addressed. We would appreciate if you could report to us any issue you find with this validator so that we can improve it.

 

 

 

 

From the above, it can be concluded that we have overcomed and resolved many issues regarding validation of metadata of data and services.

 

As Angelo (JRC) mentions, we must urgently proceed in registering the new endpoint of Cyprus Geoportal in order for the new resources to appear in the INSPIRE Geoportal. 

 

Please be kind enough to proceed as soon as possible with this issue, advising me accordingly.

 

The link you should use in order to register the new endpoint is the below:

 

https://ies-svn.jrc.ec.europa.eu/login?back_url=https%3A%2F%2Fies-svn.jrc.ec.europa.eu%2Fissues%2F2664

 

If you need further information or have any questions please do let me know.

 

Regards,

 

N. Neocleous

#37 Updated by Angelo Quaglia almost 4 years ago

  • Proactive set to No

Dear Andreas,

you need to:

1) deactivate the registration of the current endpoint

2) register the new endpoint (please ask for confirmation but I assume is http://eservices.dls.moi.gov.cy/geoportal_inspire/csw )

 

You can perform both by connecting to the INSPIRE Geoportal Discovery Service Register at http://inspire-geoportal.ec.europa.eu/INSPIRERegistry/

Instructions are here: https://ies-svn.jrc.ec.europa.eu/projects/mig-inspire/wiki/DiscoveryServiceRegister#Connecting-to-the-Discovery-Service-Register

Point 2 is exactly the same as what you did a few months ago except for the CSW endpoint which is different.

 

Point 1 requires you to follow the instruction similar to:

https://ies-svn.jrc.ec.europa.eu/projects/mig-inspire/wiki/DiscoveryServiceRegister#Modifying-an-existing-Discovery-Service-registration

BUT INSTEAD OF CLICKING ON "APPLY MODIFICATIONS" YOU WILL HAVE TO CLICK ON "DEACTIVATE" 

I will add this new section to the documentation but only tomorrow because I am attending a training today and I am out of office.

 

 

 

 

 

 

#38 Updated by Andreas Hadjiraftis almost 4 years ago

Dear Angelo,

 

Thank you for the clarifications.

 

I have cancelled the previous endpoint, as instructed.

 

I tried to create a new submission providing the new endpoint (http://eservices.dls.moi.gov.cy/geoportal_inspire/csw?Request=GetCapabilities&Service=CSW&Version=2.0.2).

When I pree 'submit", unfortunately the system is stack for a long time and I get the message: "waiting for inspire-geoportal.ec.europa.eu..."

 

I tried the same procedure twice, with no success.

 

Any ideas on how I can proceed?

 

Regards,

Andreas

#39 Updated by Angelo Quaglia almost 4 years ago

Dear Andreas,

The system was and is quite busy harvesting and serving validation requests.

I will tell you as soon as the load has lowered a bit.

I am sorry for the inconvenience.

 

Angelo

#40 Updated by Andreas Hadjiraftis almost 4 years ago

OK

I will wait.

Thanks.

#41 Updated by Angelo Quaglia almost 4 years ago

Dear Andreas, the situation has eased a bit.

It might be worth try.

Angelo

#42 Updated by Angelo Quaglia almost 4 years ago

I confirm the system is no more under heavy load.

#43 Updated by Andreas Hadjiraftis almost 4 years ago

Completed successfully.

Thanks.

Have a nice weekend.

Andreas

#44 Updated by Angelo Quaglia almost 4 years ago

Dear Andreas,

the INSPIRE Geoportal has succesfully harvested from the new endpoint.

Here is the validation report:

http://inspire-geoportal.ec.europa.eu/GeoportalProxyWebServices/resources/INSPIREResource/INSPIRE-db3ec3d9-7bfb-11e6-b44d-52540023a883_20160919-064057/services/1/PullResults/

 

The average conformity of ISO 19139 metadata is 100%, congratulations!

You rank first in the daily report(*) ex-aequo with other two Member States.

Now, you have both dataset and service metadata:

 

There is some work to be done on the Network Services which I will analyse tomorrow. From what I can see, 

http://inspire-geoportal.ec.europa.eu/resources/INSPIREResourcesReports/resourcesReport_2016-09-19/#Summary%20of%20ISO%20Metadata%20%20resources%20Per%20Country/Discovery%20Service

 

However, there is a redundant registration of the old endpoint:

it is the one in red, in the following picture:.

Could you please deactivate the registration in red color above?

 

 

(*)Summary of ISO Metadata  resources Per Country/Discovery Service
 

Discovery Service Country Discovery Service Virtual Endpoint Alias Available Resources Expected Resources Retrieved Resources Resource Types Average Metadata Conformity XML Schema Validation (ISO Metadata) Failed/Passed INSPIRE Metadata Validation Failed/Passed Latest available Member State Discovery Service Report (data might differ)
 BG
Услуга за откриване
BG_MIL 20 20 20
 
100.00%
 0 / 20  0 / 20  Report
 CY
This is a geoportal exposing INSPIRE Discovery service metadata capabilities (organization name)
  94 94 94
 
100.00%
 0 / 94  0 / 94  Report
 MT
Malta CSW (Malta Information Technology Agency)
MT_GOV 214 214 214
 
100.00%
 0 / 214  0 / 214  Report
 EE
Estonia Discovery Service. (Estonian Land Board)
EE_MAAAMET 139 139 139
 
99.89%
 0 / 139  2 / 137  Report
 SI
Inspire (SI)
SI_GOV 94 94 94
 
99.75%
 2 / 92  4 / 90  Report
 BE
GeoCatalogue de la Région de Bruxelles-Capitale (CIRB/CIBG)
BE_GEOBRU 76 76 76
 
99.70%
 0 / 76  3 / 73  Report
 BE
Geopunt-Metadatacenter zoekdienst (AGIV)
BE_AGIV 576 576 576
 
99.59%
 0 / 576  38 / 538  Report
 CY
CSW Cyprus INSPIRE Services (Ministry of Interior)
  142 142 142
 
99.57%
 142 / 0  7 / 135  Report
 BE
Metawal - Catalogue pour l'information géographique de Wallonie (Service Public de Wallonie)
BE_WALLONIE 142 142 142
 
99.41%
 4 / 138  12 / 130  Report
 LI
geocat.ch
LI_GEOCAT 57 57 57
 
99.34%
 0 / 57  6 / 51  Report
 IT
Catalogo metadati del Geoportale nazionale (Geoportale nazionale - Ministero dell'Ambiente e della...
  22891 22891 21791
 
99.17%
 90 / 21701  2694 / 19097  Report
 FI
Paikkatietohakemisto (Maanmittauslaitos)
FI_NLS 2015 2015 2015
 
98.89%
 82 / 1933  151 / 1864  Report
 CZ
Katalog metadat ČR - INSPIRE (CENIA, česká informační agentura životního prostředí)
CZ_GOV 145 145 145
 
98.63%
 20 / 125  25 / 120  Report
 PL
Geoportal - Polska Usługa Wyszukiwania INSPIRE (Centralny Ośrodek Dokumentacji Geodezyjnej i Kartograficznej)
PL_GOV 43161 43161 43159
 
98.51%
 1020 / 42139  8318 / 34841  Report
 RO
Serviciul de căutare al geo-portalului INSPIRE al României (ANCPI)
RO_ANCPI 165 165 165
 
98.46%
 0 / 165  40 / 125  Report
 LT
Geoportal of Lithuania exposing INSPIRE Discovery service metadata capabilities (VĮ Distancinių tyrimų ir geoinforma...
LT_GIS-CENTRAS 69 69 69
 
98.12%
 18 / 51  22 / 47  Report
 LV
Latvian Geospatial Information Agency metadata catalogue
LV_LGIA 67 67 67
 
98.01%
 1 / 66  20 / 47  Report
 DE
Geodatenkatalog.de
DE_GDI-DE 36924 36924 36924
 
97.83%
 65 / 36859  9552 / 27372  Report
 HR
NIPP kataloška usluga (Državna geodetska uprava)
HR_NIPP 133 133 133
 
97.61%
 23 / 110  44 / 89  Report
 NL
CSW Nationaal GeoRegister (NGR): INSPIRE zoekdienst (Beheer PDOK)
NL_KADASTER 455 455 455
 
97.08%
 35 / 420  155 / 300  Report
 AT
INSPIRE Geo-Portal Katalogservice BMLFUW/Österreich (Bundesministerium für Land- und Forstwirtschaft, Umwelt und Was...
AT_BMLFUW 925 925 925
 
96.74%
 90 / 835  373 / 552  Report
 HU
FÖMI catalog service / FÖMI katalógus szolgáltatás
HU_FOMI 51 51 51
 
96.66%
 2 / 49  23 / 28  Report
 LV
Latvijas metadatu katalogs. ĢDS (Ģeotelpisko datu savietotājs) (organization name)
LV_VISS 143 143 143
 
96.57%
 0 / 143  76 / 67  Report
 SE
Nationell svensk metadatakatalog
SE_GEODATA 464 464 464
 
95.94%
 210 / 254  146 / 318  Report
 PT
Serviço de Catálogo do Sistema Nacional de Informação Geográfica (Geoportal 1.2.4 - OGC CSW 2.0.2 ISO AP)
PT_SNIG 1847 1847 1847
 
95.74%
 0 / 1847  1021 / 826  Report
 IE
Geoportal IE - INSPIRE Discovery Service (Department of Environment, Community and Local Government)
IE_ENVIRON 71 71 71
 
95.70%
 0 / 71  40 / 31  Report
 LU
INSPIRE Geoportal CSW of the Grand-Duchy of Luxembourg (organization name)
LU_ACT 281 281 281
 
95.02%
 0 / 281  237 / 44  Report
 NO
Geonorge metadataportal (SKLD)
NO_GEONORGE 649 649 649
 
92.13%
 540 / 109  609 / 40  Report
 IS
Iceland Service
IS_LMI 132 132 132
 
91.67%
 0 / 132  122 / 10  Report
 UK
UK Location Catalogue Publishing Service (Ordnance Survey, GB)
UK_GOV 23466 23466 23445
 
91.60%
 32 / 23413  22537 / 908  Report
 ES
IDEE Discovery service (CNIG en nombre del Consejo Superior Geográfico)
ES_IDEE 4675 4675 4675
 
89.23%
 947 / 3728  1943 / 2732  Report
 FR
Geocatalogue Catalogue Server INSPIRE (BRGM)
FR_BRGM 34621 34621 34371
 
88.91%
 5193 / 29178  34092 / 279  Report
 BE
CSW service of the belgian federal government (National geographic Institute/DG-INSPIRE)
BE_FEDERAL 89 89 89
 
88.77%
 19 / 70  21 / 68  Report
 EL
ΚΑΤΑΛΟΓΟΣ (Elena)
EL_OKXE 30 30 30
 
87.99%
 28 / 2  30 / 0  Report
 DK
Geodata-info.dk søgetjeneste (Styrelsen for Dataforsyning og Effektivisering)
DK_GST 282 282 282
 
87.70%
 2 / 280  264 / 18  Report
 SK
Katalógová služba Národného Geoportálu (Slovenská agentúra životného prostredia)
SK_SAZP 413 413 413
 
86.27%
 3 / 410  285 / 128  Report


#45 Updated by Angelo Quaglia almost 4 years ago

Dear Andreas,

could you please confirm whether you intend to deactivate the registration of the old end point that I htink was re-registered by mistake?

 

Best regards,

Angelo

#46 Updated by Angelo Quaglia almost 4 years ago

  • Country set to CY - Cyprus

#47 Updated by Andreas Hadjiraftis almost 4 years ago

Dear Angelo,

 

Deactivated, as instructed.

 

Please confirm.

 

Regards,

Andreas

#48 Updated by Angelo Quaglia almost 4 years ago

Dear Andreas,

it's perfect, many thanks indeed for doing this promptly.

Now there is one entry for Cyprus in the INSPIRE Geoportal Daily Report:

http://inspire-geoportal.ec.europa.eu/resources/INSPIREResourcesReports/resourcesReport_2016-09-22/#Summary%20of%20ISO%20Metadata%20%20resources%20Per%20Country/Discovery%20Service

Best regards,

Angelo

 

Summary of ISO Metadata  resources Per Country/Discovery Service
 

Discovery Service Country Discovery Service Virtual Endpoint Alias Available Resources Expected Resources Retrieved Resources Resource Types Average Metadata Conformity XML Schema Validation (ISO Metadata) Failed/Passed INSPIRE Metadata Validation Failed/Passed Latest available Member State Discovery Service Report (data might differ)
 BG
Услуга за откриване
BG_MIL 20 20 20
 
100.00%
 0 / 20  0 / 20  Report
 CY
This is a geoportal exposing INSPIRE Discovery service metadata capabilities (organization name)
CY_GOV 94 94 94
 
100.00%
 0 / 94  0 / 94  Report
 MT
Malta CSW (Malta Information Technology Agency)
MT_GOV 214 214 214
 
100.00%
 0 / 214  0 / 214  Report
 EE
Estonia Discovery Service. (Estonian Land Board)
EE_MAAAMET 139 139 139
 
99.79%
 0 / 139  4 / 135  Report
 SI
Inspire (SI)
SI_GOV 94 94 94
 
99.75%
 2 / 92  4 / 90  Report
 BE
GeoCatalogue de la Région de Bruxelles-Capitale (CIRB/CIBG)
BE_GEOBRU 76 76 76
 
99.70%
 0 / 76  3 / 73  Report
 BE
Geopunt-Metadatacenter zoekdienst (AGIV)
BE_AGIV 576 576 576
 
99.59%
 0 / 576  38 / 538  Report
 BE
Metawal - Catalogue pour l'information géographique de Wallonie (Service Public de Wallonie)
BE_WALLONIE 142 142 142
 
99.41%
 4 / 138  12 / 130  Report
 LI
geocat.ch
LI_GEOCAT 57 57 57
 
99.34%
 0 / 57  6 / 51  Report
 IT
Catalogo metadati del Geoportale nazionale (Geoportale nazionale - Ministero dell'Ambiente e della...
IT_MINAMBIENTE 22983 22983 22354
 
99.17%
 102 / 22252  2789 / 19565  Report
 FI
Paikkatietohakemisto (Maanmittauslaitos)
FI_NLS 2015 2015 2015
 
98.89%
 82 / 1933  151 / 1864  Report
 CZ
Katalog metadat ČR - INSPIRE (CENIA, česká informační agentura životního prostředí)
CZ_GOV 145 145 145
 
98.58%
 20 / 125  26 / 119  Report
 PL
Geoportal - Polska Usługa Wyszukiwania INSPIRE (Centralny Ośrodek Dokumentacji Geodezyjnej i Kartograficznej)
PL_GOV 43376 43376 43374
 
98.50%
 1020 / 42354  8450 / 34924  Report
 RO
Serviciul de căutare al geo-portalului INSPIRE al României (ANCPI)
RO_ANCPI 165 165 165
 
98.46%
 0 / 165  40 / 125  Report
 LT
Geoportal of Lithuania exposing INSPIRE Discovery service metadata capabilities (VĮ Distancinių tyrimų ir geoinforma...
LT_GIS-CENTRAS 69 69 69
 
98.12%
 18 / 51  22 / 47  Report
 DE
Geodatenkatalog.de
DE_GDI-DE 36924 36924 36924
 
97.83%
 65 / 36859  9552 / 27372  Report
 LV
Latvian Geospatial Information Agency metadata catalogue
LV_LGIA 67 67 67
 
97.78%
 1 / 66  22 / 45  Report
 HR
NIPP kataloška usluga (Državna geodetska uprava)
HR_NIPP 133 133 133
 
97.61%
 23 / 110  44 / 89  Report
 NL
CSW Nationaal GeoRegister (NGR): INSPIRE zoekdienst (Beheer PDOK)
NL_KADASTER 455 455 455
 
97.10%
 35 / 420  155 / 300  Report
 AT
INSPIRE Geo-Portal Katalogservice BMLFUW/Österreich (Bundesministerium für Land- und Forstwirtschaft, Umwelt und Was...
AT_BMLFUW 924 924 924
 
96.74%
 90 / 834  373 / 551  Report
 HU
FÖMI catalog service / FÖMI katalógus szolgáltatás
HU_FOMI 51 51 51
 
96.66%
 2 / 49  23 / 28  Report
 LV
Latvijas metadatu katalogs. ĢDS (Ģeotelpisko datu savietotājs) (organization name)
LV_VISS 143 143 143
 
96.57%
 0 / 143  76 / 67  Report
 SE
Nationell svensk metadatakatalog
SE_GEODATA 464 464 464
 
95.94%
 210 / 254  146 / 318  Report
 PT
Serviço de Catálogo do Sistema Nacional de Informação Geográfica (Geoportal 1.2.4 - OGC CSW 2.0.2 ISO AP)
PT_SNIG 1847 1847 1847
 
95.74%
 0 / 1847  1021 / 826  Report
 IE
Geoportal IE - INSPIRE Discovery Service (Department of Environment, Community and Local Government)
IE_ENVIRON 71 71 71
 
95.70%
 0 / 71  40 / 31  Report
 LU
INSPIRE Geoportal CSW of the Grand-Duchy of Luxembourg (organization name)
LU_ACT 281 281 281
 
95.02%
 0 / 281  237 / 44  Report
 NO
Geonorge metadataportal (SKLD)
NO_GEONORGE 641 641 641
 
91.99%
 530 / 111  603 / 38  Report
 IS
Iceland Service
IS_LMI 137 137 137
 
91.88%
 0 / 137  123 / 14  Report
 UK
UK Location Catalogue Publishing Service (Ordnance Survey, GB)
UK_GOV 23445 23445 23445
 
91.59%
 33 / 23412  22535 / 910  Report
 ES
IDEE Discovery service (CNIG en nombre del Consejo Superior Geográfico)
ES_IDEE 4675 4675 4675
 
89.23%
 947 / 3728  1943 / 2732  Report
 FR
Geocatalogue Catalogue Server INSPIRE (BRGM)
FR_BRGM 34092 34092 33692
 
89.02%
 5126 / 28566  33440 / 252  Report
 BE
CSW service of the belgian federal government (National geographic Institute/DG-INSPIRE)
BE_FEDERAL 89 89 89
 
88.77%
 19 / 70  21 / 68  Report
 EL
ΚΑΤΑΛΟΓΟΣ (Elena)
EL_OKXE 30 30 30
 
87.99%
 28 / 2  30 / 0  Report
 DK
Geodata-info.dk søgetjeneste (Styrelsen for Dataforsyning og Effektivisering)
DK_GST 282 282 282
 
87.70%
 2 / 280  264 / 18  Report
 SK
Katalógová služba Národného Geoportálu (Slovenská agentúra životného prostredia)
SK_SAZP 413 413 413
 
86.27%
 3 / 410  285 / 128  Report

#49 Updated by Andreas Hadjiraftis almost 4 years ago

URGENT

Dear Angelo,

It was great to meet you in Barcelona during the INSPIRE Conference.

I have faced the following problem:

I was trying to access INSPIRE web page this morning, and I could not locate Cyprus.

http://inspire.ec.europa.eu/document-tags/inspire-your-country

Please see the attached screen shot.

Is there a reason for this?

All the rest EU member states are listed (table and map).

Could you please investigate and inform us accordingly?

Regards,

Andreas Hadjiraftis

#50 Updated by Angelo Quaglia almost 4 years ago

Dear Andreas,

indeed, it was great to meet you.

The problem you describe is about the INSPIRE Web Site and not the INSPIRE Geoportal.

My colleague Loizos Bailas (who sits in front of me) has already fixed the problem.

That is documented in a separate Issue #2868 I created.

Many thanks for your feedback.

Best regards,

Angelo

Also available in: Atom PDF