Support #2756

ES - Ministerio de Agricultura: Question about the validation report of a metadata

Added by Germán Bravo Aldea over 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:21 Apr 2016
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:Validation outcome
Target version:-
Submitting Organisation:ES - Ministerio de Agricultura Knowledge-Base relevant?:
Proactive: Keyword #1:
Country:ES - Spain Keyword #2:
Originating UI: Keyword #3:

Description

Hello,


I send you a curious behavior  that we observed in the validator.


We are modifying the metadata "Demarcaciones hidrográficas (ámbito terrestre y marino)" with uuid=95b8abce-2083-40b3-bd6b-83a7d8a72307 (See geonetwork_terrestreymarino.xml attached),  when we downloaded the XML of geonetwork and try to validate get this error:

 

If the same XML add a comment or a new line empty for example in to line 562 of the original XML (see geonetwork_comment_terrestreymarino.xml, geonetwork_newline_terrestreymarino.xml attached) , the metadata is valid without error.

can you tell me that the first XML has an error?


Greetings and thank you.

 

 

 

 

 

geonetwork_comment_terrestreymarino.xml Magnifier - XML with comment (39.4 KB) Germán Bravo Aldea, 21 Apr 2016 04:46 pm

geonetwork_terrestreymarino.xml Magnifier - Original XML (39.3 KB) Germán Bravo Aldea, 21 Apr 2016 04:46 pm

geonetwork_newline_terrestreymarino.xml Magnifier - XML with new line (39.3 KB) Germán Bravo Aldea, 21 Apr 2016 04:46 pm

History

#1 Updated by Angelo Quaglia over 4 years ago

  • Description updated (diff)
  • Status changed from New to Assigned

Dear German,

I think I might have noticed this metadata file in the past already.

The metadata looks fine.

The validator was getting confused probably by a specific character ir byte sequence in the file.

This problem might have gone away with some other fix because I do not get any error on my internal machine.

However, I am testing on a Windows machine.

I will check again as soon as I get the solution running on a Linux machine.

I do not yet know if it has anything to do with the problem but I tried to validate the file with the W3C validator:

https://validator.w3.org/check?uri=http%3A%2F%2Finspire-geoportal.ec.europa.eu%2Fresources%2Fsandbox%2FINSPIRE-04d29bc2-079d-11e6-9c5d-52540023a883_20160421-104245%2Fdownloaded&charset=%28detect+automatically%29&doctype=Inline&group=0

 

 

#2 Updated by Germán Bravo Aldea about 4 years ago

  • % Done changed from 0 to 100

Dear Angelo,

We have published a new version of metadata Demarcaciones hidrográficas (ámbito terrestre y marino) http://www.magrama.gob.es/ide/metadatos/srv/spa/xml_iso19139?uuid=95b8abce-2083-40b3-bd6b-83a7d8a72307 .

This new version don't have the problem of the Ascii character, we only have returned to save the XML in UTF-8 and the problem was solved.

For me this Issue #2756  is complete, and everything is ok.

Thank you very much for your cooperation. A greeting.

#3 Updated by Angelo Quaglia about 4 years ago

  • Status changed from Assigned to Closed

Dear German,

again, I appreciate you came back to give your feedback.

Best regards,

Angelo

#4 Updated by Angelo Quaglia almost 4 years ago

  • Category set to Validation outcome

#5 Updated by Angelo Quaglia almost 4 years ago

  • Country set to ES - Spain

Also available in: Atom PDF