Support #2789

RO - Teamnet: WMS view service layer metadata

Added by Daniel Urda about 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:13 Jun 2016
Priority:NormalDue date:
Assignee:Angelo Quaglia% Done:

0%

Category:Validation outcome
Target version:-
Submitting Organisation:RO - Teamnet Knowledge-Base relevant?:
Proactive: Keyword #1:
Country:RO - Romania Keyword #2:
Originating UI: Keyword #3:

Description

We have been trying to make our WMS View Service (metadata available here: http://geoportal.gov.ro/Geoportal_INIS/rest/document?id={DDA4337F-0B94-4625-B99E-7316CD6DD26F}  )  fully compliant with INSPIRE. While we are aware we currently have some performance problems (the service doesn't always reply without 5 seconds), we are also getting the following issue, which we would not have expected otherwise:

  • The metadata about one or more View Service Layers is not complete.
Expert documentation

Is this issue related to the fact that some of the GetMap request do not reply in the expected time, or is there something we missed when publishing our metadata and WMS capabilites?

We tried comapring our metadata with other compliant services from the Resource Browser (http://inspire-geoportal.ec.europa.eu/proxybrowser/), however when manually validating the View services "with no issue at all" we get various issues, including the one described above.

 

Thank you,

Daniel Urda

 


Related issues

Related to Geoportal Helpdesk - Support #2787: CZ: Dimension pairs specific parameter Closed 12 Jun 2016

History

#1 Updated by Angelo Quaglia about 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Angelo Quaglia

Dear Daniel,

it is a bug, as explained in Issue #2787.

The fix will be deployed tonight.

Best regards,
Angelo

#2 Updated by Angelo Quaglia about 4 years ago

  • Status changed from Assigned to Resolved

Please try now.

I have just tried and only the timeout issue is reported:

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-3c3d0a12-3170-11e6-af6c-52540023a883_20160613-160759/

 

Many thanks for reporting this issue.

Best regards,

Angelo

#3 Updated by Angelo Quaglia about 4 years ago

From: Daniel Urda [mailto:daniel.urda.ct@gmail.com]
Sent: 15 June 2016 07:35
To: Angelo Quaglia <angelo.quaglia@ext.jrc.ec.europa.eu>
Subject: Enquiry regarding INSPIRE MD Validation statistics

 

Dear Angelo,

First thank you for your work making sure the validator works as intended, as it greatly helped us in understanding issues with our INSPIRE services that were not readily apparent.

We would like to known when it would be possible to update the validation for the Romanian INSPIRE services, as available in the Geoportal Resource Browser? The verification of last night unfortunately hit a maintenance downtime period (17:00-17:30 GMT) when we were upgrading the hardware on our servers, and consequently the WMS and WFS services were not accessible.

We had prepared for today the presentation of our result to the Romanian INSPIRE community, and we thought presenting the statistics for Romania would help deliver the message that the target set by the INSPIRE technical guidelines can be reached with the tools currently available on the market. Unfortunately, without the validity information publicly verifiable on the EC Geoportal (e.g. the failed validation due to our server being inaccessible) we fear some of the presenters may have reservation accepting such a message.

Thank you,

Daniel Urda

#4 Updated by Angelo Quaglia about 4 years ago

From: Angelo Quaglia [mailto:angelo.quaglia@ext.jrc.ec.europa.eu]
Sent: 15 June 2016 10:40
To: 'Daniel Urda' <daniel.urda.ct@gmail.com>
Subject: RE: Enquiry regarding INSPIRE MD Validation statistics

 

Dear Daniel,

It’s running now.

It will take a few minutes.

I will notify you as soon as it is done.

 

Bet regards,

Angelo

#5 Updated by Angelo Quaglia about 4 years ago

From: Angelo Quaglia [mailto:angelo.quaglia@ext.jrc.ec.europa.eu]
Sent: 15 June 2016 10:52
To: 'Daniel Urda' <daniel.urda.ct@gmail.com>
Subject: RE: Enquiry regarding INSPIRE MD Validation statistics

 

Dear Daniel,

It’s done.

http://inspire-geoportal.ec.europa.eu/resources/INSPIRE-7edbed58-ddbc-11e4-b469-52540004b857_20160615-103726/services/1/PullResults/

 

I suggest you go to the resource browser :

http://inspire-geoportal.ec.europa.eu/proxybrowser/?msdsResourceLocator=/INSPIRE-7edbed58-ddbc-11e4-b469-52540004b857_20160615-103726/services/1/PullResults&msdsCountryCode=RO

 

 

and select downloadservicedataset

 

The gallery (FlashPlayer plugin needed) will show Downloadable datasets that are also viewable.

 

 

 

Great work, congratulations

 

Best regards,
Angelo

#6 Updated by Angelo Quaglia about 4 years ago

From: Daniel Urda [mailto:daniel.urda.ct@gmail.com]
Sent: 15 June 2016 11:00
To: Angelo Quaglia <angelo.quaglia@ext.jrc.ec.europa.eu>
Subject: Re: Enquiry regarding INSPIRE MD Validation statistics

 

Dear Angelo,

Thank you very much. The validation results, and indeed the links you provided, are really helpful to us.

Best regards,

Daniel Urda

#7 Updated by Angelo Quaglia about 4 years ago

  • Subject changed from WMS view service layer metadata to RO - Teamnet: WMS view service layer metadata

2016-06-16 13:02 GMT+03:00 Angelo Quaglia <angelo.quaglia@ext.jrc.ec.europa.eu>:

Dear Daniel,

How did it go, yesterday, if I may ask?

 

Best regards,

Angelo

#8 Updated by Angelo Quaglia about 4 years ago

From: blueeagletm@gmail.com [mailto:blueeagletm@gmail.com] On Behalf Of Daniel
Sent: 16 June 2016 16:02
To: Angelo Quaglia <angelo.quaglia@ext.jrc.ec.europa.eu>
Subject: Re: Enquiry regarding INSPIRE MD Validation statistics

 

Dear Angelo,

The presentation went very well. The day-long session dealt with the process of publishing View and Download services from existing data, with one of our presentations discussing how to ensure service metadata conformity with the INSPIRE regulations. Some of the attendants (which included representatives of Romanian public institutions participating in the national Network Services group) were only aware of the Romanian metadata validator (which tests exclusively the GMD document and not the Capabilities or the relation between Service MD, Service Capabilities and Dataset MD) and thus had trouble understanding the results of the EU Geoportal validation statistics. The above-mentioned presentation listed common issues with the Capabilities documents as well as possible solutions. While I don't have direct access to the feeback given by attendees, my understanding is that the session was well-received. Thank you again for your help in revalidating in the Romanian services, as well as your previous support.

Best regards,

Daniel Urda

#9 Updated by Angelo Quaglia almost 4 years ago

  • Category set to Validation outcome

#10 Updated by Angelo Quaglia almost 4 years ago

  • Tracker changed from Bug to Support

#11 Updated by Angelo Quaglia almost 4 years ago

  • Status changed from Resolved to Closed

#12 Updated by Angelo Quaglia almost 4 years ago

  • Country set to SE - Sweden

#13 Updated by Angelo Quaglia almost 4 years ago

  • Country changed from SE - Sweden to RO - Romania

Also available in: Atom PDF