Support #2961

CY - Department of Lands and Surveys, Ministry of Interior: INSPIRE Implementation in Cyprus

Added by Angelo Quaglia over 3 years ago. Updated about 2 years ago.

Status:FeedbackStart date:14 Mar 2017
Priority:NormalDue date:
Assignee:Angelo Quaglia% Done:

0%

Category:Harvesting results
Target version:-
Submitting Organisation:CY - Department of Lands and Surveys, Ministry of Interior Knowledge-Base relevant?:
Proactive:No Keyword #1:
Country:CY - Cyprus Keyword #2:
Originating UI: Keyword #3:

Description

 
rom: Andreas Hadjiraftis [ahadjiraftis@dls.moi.gov.cy]
Sent: 14 March 2017 09:08
To: angelo.quaglia@ext.jrc.ec.europa.eu
Subject: INSPIRE Implementation in Cyprus
 
 

Dear Angelo,

 

We are currently very busy, among others, with INSPIRE implementation in Cyprus.

 

It is very important for us to know when JRC is planning to proceed with testing the actual data services.

 

We understand that all basic tests regarding metadata have already been completed.

 

Please confirm.

 

 

Andreas Hadjiraftis

 

metadataEditor.jpg - metadata editor print screen (71.2 KB) Antonis Papantoniou, 07 May 2018 11:58 am

2462

History

#1 Updated by Angelo Quaglia over 3 years ago

  • Status changed from Assigned to Feedback
From: QUAGLIA Angelo (JRC-ISPRA-EXT)
Sent: 14 March 2017 10:28
To: Andreas Hadjiraftis
Subject: RE: INSPIRE Implementation in Cyprus
 
 
Dear Andreas,
 
Personally, I am very impressed with the work Cyprus is doing.
 
Coming to your questions:
 
1) The tests performed by the validator of the INSPIRE Geoportal are intended to help Member States know they are on the good track and to give them an approximate quantitative measure of where they are with the implementation of INSPIRE.
 
Please keep in mind that they are in no way final nor complete, also because some tests cannot be automated.
The INSPIRE Geoportal will not be able, at least at the beginning, to validate all the data of all Member States, both for capacity reasons but also because some Member States might not want us to do so for various reasons.
 
Currently, I am already using your services and data, together with those of other Member States, to test my developments.
 
I will be able to update the external validator by the end of this month.
 
Concerning the data and the services, the upcoming deadline is the following one which is critical because all Annex I datasets, i.e. not only those that are "Newly collected and extensively restructured", will have to be INSPIRE compliant:
 
 

7§39(a)

23/11/2017

Implementation of Commission Regulation (EU) No 1089/2010 of 23 November 2010(link is external) implementing Directive 2007/2/EC of the European Parliament and of the Council as regards interoperability of spatial data sets and services for other Annex I spatial data sets still in use at the date of adoption

 
 
 
2) Regarding the metadata please be aware that new Technical Guidelines for Metadata have been published, which introduce some changes.
However, "To facilitate a smooth transition from version 1.3 to version 2.0, a transitional period of 3 years has been defined, starting from 19 December 2016. During this period, the metadata records compliant with both version 1.3 and 2.0 implementations will be considered as “compliant with the INSPIRE Technical Guidelines for Metadata”. During the transitional period, the validator used in the INSPIRE geoportal will validate against and will provide validation reports for both versions 1.3 and 2.0. The better result will be used for the value of the compliance meter. After the transitional period, the geoportal will only validate against version 2.0."
 
 
Best regards,
Angelo
 

#2 Updated by Angelo Quaglia over 2 years ago

  • Status changed from Feedback to Resolved

Dear Andreas,

as of today, Cyprus is providing metadata for 42 datasets and 52 services:

Average Metadata completeness is 100%

Average Interoperability/Linkage Indicator is 45.74%

 

There are 16 datasets (annex i(4) annex iii(12))  for which a Download Service cannot be found:

http://inspire-geoportal.ec.europa.eu/proxybrowser/#fq=memberStateCountryCode%3Acy&fq=sourceMetadataResourceLocator%3A%5C%2F*&fq=missingInteroperabilityAspect%3ADOWNLOAD_MATCHING_DATA_IS_AVAILABLE&q=*%3A*

 

There are  16 datasets (annex i(4) annex iii(12)) for which a View Service cannot be found:

http://inspire-geoportal.ec.europa.eu/proxybrowser/#fq=memberStateCountryCode%3Acy&fq=sourceMetadataResourceLocator%3A%5C%2F*&fq=missingInteroperabilityAspect%3ALAYER_MATCHING_DATA_IS_AVAILABLE&q=*%3A*

 

Best regards,

Angelo

#3 Updated by Angelo Quaglia over 2 years ago

Dear Andreas,

as per your kind request, I am reviewing the situation presented above:

There are 16 datasets (annex i(4) annex iii(12))  for which a Download Service cannot be found:

http://inspire-geoportal.ec.europa.eu/proxybrowser/#fq=memberStateCountryCode%3Acy&fq=sourceMetadataResourceLocator%3A%5C%2F*&fq=missingInteroperabilityAspect%3ADOWNLOAD_MATCHING_DATA_IS_AVAILABLE&q=*%3A*

 

I will go through the first of those datasets in detail as an example.

In summary, the Atom service that serves this dataset:

(dataset) ANNEX 3 | Habitats and Biotopes - Department of Forests (Metadata of Data) (Department of Lands and Surveys)

contains a link to the metadata of this other dataset:

(dataset) ANNEX 3 | Habitats and Biotopes - Department of Environment (Metadata of Data) (Department of Lands and Surveys)

Here is the detailed analysis:

Dataset Title fileIdentifier Unique Resource Identifier Results found in the Resource Browser for 9706A340-D7DA-47DE-9EEB-8DFE187A1A49

(dataset) ANNEX 3 | Habitats and Biotopes - Department of Forests (Metadata of Data) (Department of Lands and Surveys)

{3DB4F361-DF93-4B8B-9682-1CCC0DAD5AF0}
Code: {9706A340-D7DA-47DE-9EEB-8DFE187A1A49}
Code: {017B11FD-2EE7-46FE-BB90-B38F75A337E7}, Namespacehttp://moi.gov.cy/
       
       

 

Everything seems fine but the problem is in the Atom Service, more specifically in the link to the metadata of the Spatial Data Set:

http://weba.dls.moi.gov.cy/arcgis/rest/directories/arcgisforinspire/INSPIRE/HB_HabitatBiotop_MapServer/serviceatoma1.xml?service=wfs

 

       <author>

             <name>Neoklis Neokleous</name>

             <email>director@dls.moi.gov.cy</email>

       </author>

       <entry>

             <inspire_dls:spatial_dataset_identifier_code>%7B669C0A16-2217-4EE0-9916-EB7C67CBB326%7D</inspire_dls:spatial_dataset_identifier_code>

       <inspire_dls:spatial_dataset_identifier_namespace>http://moi.gov.cy/</inspire_dls:spatial_dataset_identifier_namespace>

              <link href="http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7BB289D9FD-672D-401E-8F33-E9DC8A836648%7D" rel="describedby" type="application/vnd.iso.19139+xml"/>

The link http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id={B289D9FD-672D-401E-8F33-E9DC8A836648}

points to the metadata of a different dataset:

Dataset Title fileIdentifier Unique Resource Identifier Results found in the Resource Browser for 38CB0FF4-2AB9-4647-800F-BF0A7DB5BB26

(dataset) ANNEX 3 | Habitats and Biotopes - Department of Environment (Metadata of Data) (Department of Lands and Surveys)

{2FBE345F-ABAE-4863-8D26-339B188F8C3F}
Code: {38CB0FF4-2AB9-4647-800F-BF0A7DB5BB26}
Code: {669C0A16-2217-4EE0-9916-EB7C67CBB326}, Namespacehttp://moi.gov.cy/
     

 

Best regards,

Angelo

 

#4 Updated by Antonis Papantoniou over 2 years ago

Hello Angelo,

I have made a change in the url of Metadata of Data for the Department of Forests, within the ArcGIS Service.

Could you review again now please and let me know your feedback, if this corrects the issue so that i could proceed with other datathemes?

Thanks,

Antonis

#5 Updated by Angelo Quaglia over 2 years ago

  • Status changed from Resolved to Feedback

Dear Antonis,

If I open the atom based service:

http://weba.dls.moi.gov.cy/arcgis/rest/directories/arcgisforinspire/INSPIRE/HB_HabitatBiotop_MapServer/serviceatoma1.xml?service=wfs

I see:

       <entry>

          <inspire_dls:spatial_dataset_identifier_code>%7B669C0A16-2217-4EE0-9916-EB7C67CBB326%7D</inspire_dls:spatial_dataset_identifier_code>

          <inspire_dls:spatial_dataset_identifier_namespace>http://moi.gov.cy/</inspire_dls:spatial_dataset_identifier_namespace>

             <link href="http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7BB289D9FD-672D-401E-8F33-E9DC8A836648%7D" rel="describedby" type="application/vnd.iso.19139+xml"/>

 

It still looks the same to me:

http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id={B289D9FD-672D-401E-8F33-E9DC8A836648"

http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id={B289D9FD-672D-401E-8F33-E9DC8A836648

 

Do you perhaps need to republish the service?

Best regards,

Angelo

 

#6 Updated by Antonis Papantoniou over 2 years ago

I have made the changes unter the inspire View Service properties for each layer.

Maybe this is not enough. I will try to find out how the atom file can change (i assume only serviceatoma.xml needs to be changed) and make the change there as well.

#7 Updated by Antonis Papantoniou over 2 years ago

Just to clarify that the Service Habitats and Biotopes service data from two different Stakeholders. 

Data originated from the Department of Environment concerning the distribution of habitats in Cyprus and data originated from the Department of Forests concerning Lara Toxeftra Marine Protected Area.

Thus we have created two separate metadata of data, one per Stakeholder.

#8 Updated by Angelo Quaglia over 2 years ago

Dear Antonis,

Many thanks for the clarification.

It is important that the View and Download Services contain enough information for the INSPIRE Geoportal to determine the linkage with the Spatial Data Set(s) they offer.

For WMS View Services and Atom Download Services, the crucial information consists in the links to the Spatial Data Set metadata:

  • For WMS View Services, the information is located in the metadataURL element inside the layer definitions (in the capabilities document).
  • For Atom Download Services, the  information is located in <link rel="describedby"> element inside the entries elements (in the top Atom feed document).

Best regards,

Angelo

 

#9 Updated by Antonis Papantoniou over 2 years ago

So i need to edit the serviceatoma1.xml file and under <link rel="describedby"> edit the information with the metadata urls for the two datasets?

ANNEX 3 | Habitats and Biotopes - Department of Environment (Metadata of Data)

http://eservices.dls.moi.gov.cy/geoportal_inspire/catalog/search/resource/details.page?uuid=%7BB289D9FD-672D-401E-8F33-E9DC8A836648%7D

 

ANNEX 3 | Habitats and Biotopes - Department of Forests (Metadata of Data)

http://eservices.dls.moi.gov.cy/geoportal_inspire/catalog/search/resource/details.page?uuid=%7BD4848C14-6000-4269-ABD3-0760984C435E%7D

#10 Updated by Angelo Quaglia over 2 years ago

That is correct.

Actually, since your datasets Unique Resource Identifier code matches the fileIdentifier of the metadata, you can easily spot the inconsistencies:

       <entry>

          <inspire_dls:spatial_dataset_identifier_code>%7B669C0A16-2217-4EE0-9916-EB7C67CBB326%7D</inspire_dls:spatial_dataset_identifier_code>

          <inspire_dls:spatial_dataset_identifier_namespace>http://moi.gov.cy/</inspire_dls:spatial_dataset_identifier_namespace>

             <link href="http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7BB289D9FD-672D-401E-8F33-E9DC8A836648%7D" rel="describedby" type="application/vnd.iso.19139+xml"/>

 

In your implementation, the following two must match:

669C0A16-2217-4EE0-9916-EB7C67CBB326

B289D9FD-672D-401E-8F33-E9DC8A836648

 

#11 Updated by Antonis Papantoniou over 2 years ago

would it be better if I to do the change in the metadata editor instead of the atom?

As the image attached shows?

 

 

#12 Updated by Antonis Papantoniou over 2 years ago

should we make the change On both metadataEditor and atom and keep one of the two values?

either 

669C0A16-2217-4EE0-9916-EB7C67CBB326

or

B289D9FD-672D-401E-8F33-E9DC8A836648

#13 Updated by Angelo Quaglia over 2 years ago

Dear Antonis,

that depends on your specific implementation (ESRI, perhaps?).

If a change in the metadata propagates to the services, then I assume it would work. However, you need to ask your software vendor to know the exact steps and the expected results.

 

I have described to you what is needed to make things to work in the INSPIRE Geoportal.

I cannot tell you what steps you need to take using your software.

 

Best regards,

Angelo

#14 Updated by Antonis Papantoniou over 2 years ago

Dear Angelo,

Thank you for your promt responce. From what i understand based on your comments is that there are two issues we need to resolve:

a) add values in the atom feed that relate to the second metadata record of the second Stakeholder,

b)consindering a), change the spatial_dataset_identifier_code and documend id for both entries so that they match

Regarding the proper procedure, we will advice our software vendor.

Could you please confirm the above?

Thanks,

Antonis

#15 Updated by Angelo Quaglia over 2 years ago

Dear Antonis,

I can tell you what you need to obtain.

I cannot tell you what you have to do in detail, because it depends on your implementation and your policies.

I can reiterate that:

It is important that the View and Download Services contain enough information for the INSPIRE Geoportal to determine the linkage with the Spatial Data Set(s) they offer.
For WMS View Services and Atom Download Services, the crucial information consists in the links to the Spatial Data Set metadata:
  • For WMS View Services, the information is located in the metadataURL element inside the layer definitions (in the capabilities document).
  • For Atom Download Services, the  information is located in <link rel="describedby"> element inside the entries elements (in the top Atom feed document).

 

In order to clarify further:

you take each Spatial Data Set and take note of its Unique Resource Identifier(s). Some of your datasets have more than one:

Unique Resource Identifier
Code{9307F866-AA44-427F-A222-513AB5C5B793}
Code: {07717B6B-BA26-4154-ACD1-4424CF1E4931}Namespacehttp://moi.gov.cy
 

Then you look at the ISO 19139 metadata of the Spatial Data Setand take note of its fileIdentifier that in this example DOES NOT MATCH any of the Unique Resource Identifier(s) :

 
<gmd:fileIdentifier>
<gco:CharacterString>{470A72D1-A6EE-487F-8D2D-3F53CFC36C84}</gco:CharacterString>
</gmd:fileIdentifier>
...
<gmd:identificationInfo>
<gmd:MD_DataIdentification>
<gmd:citation>
<gmd:CI_Citation>
...
<gmd:identifier>
<gmd:MD_Identifier>
<gmd:code>
<gco:CharacterString>{9307F866-AA44-427F-A222-513AB5C5B793}</gco:CharacterString>
</gmd:code>
</gmd:MD_Identifier>
</gmd:identifier>
<gmd:identifier>
<gmd:RS_Identifier>
<gmd:code>
<gco:CharacterString>{07717B6B-BA26-4154-ACD1-4424CF1E4931}</gco:CharacterString>
</gmd:code>
<gmd:codeSpace>
<gco:CharacterString>http://moi.gov.cy/</gco:CharacterString>
</gmd:codeSpace>
</gmd:RS_Identifier>
</gmd:identifier>
</gmd:CI_Citation>
 
Then you go to the service Atom top feed and ensure that in the entry corresponding to the dataset, the link(rel="describedby") correctly points to the ISO 19139 metadata of the dataset.
How you do this, it is not something I can possibly know.
 
<feed>
...
<entry>
...
   <!-- link to ISO MD of the dataset -->
   <link rel="describedby" href="http://YOURDISCOVERY?   service=CSW&amp;VERSION=2.0.2&amp;REQUEST=GetRecordById&amp;OUTPUTSCHEMA=http://www.isotc211.org/2005/gmd&amp;ELEMENTSETNAME=full&amp;ID=%7B470A72D1-A6EE-487F-8D2D-3F53CFC36C84%7D"    type="application/xml" hreflang="en" title="Metadata"/>
...
</entry>
...
</feed>
 
 
Best regards,
Angelo
 
 

#16 Updated by Antonis Papantoniou about 2 years ago

Dear Angelo,

 

You have mentioned that 16 Download Services cannot be found. How can I identify which are these specific Download Services?

By clicking on the below URL you have provided in previous conversation? If yes, this provides me with information for all 31 Services.

http://inspire-geoportal.ec.europa.eu/proxybrowser/#fq=memberStateCountryCode%3Acy&fq=sourceMetadataResourceLocator%3A%5C%2F*&fq=missingInteroperabilityAspect%3ADOWNLOAD_MATCHING_DATA_IS_AVAILABLE&q=*%3A

 

Thanks,

Antonis

 

 

#17 Updated by Angelo Quaglia about 2 years ago

Il 11/05/18, alle 10:37, Antonis ha scritto:

> hello angelo. I updated the issue in geoportal helpdesk, can you review please?

#18 Updated by Angelo Quaglia about 2 years ago

Dear Anotnis,

I will try to help you but please note that I do not have terminal access to the server from the outside and the office is closed since Wendesday and the rest of this week.

I actually asked to be allowed to come at least on Friday, but at least one permament staff must be present and no one was available.

Best regards,

Angelo

#19 Updated by Angelo Quaglia about 2 years ago

 

Dear Antonis,

Yes, that is the link.

For example, it returns this records, for which no Download Service dataset is found by the INSPIRE Geoportal:

 

This dataset has this identifier

Unique Resource Identifier
Code: {03833C18-2A59-4A36-922C-50D208493DA5}

 

Which is the Download Service that is supposed to server that dataset?

Assume that it is this one:

(service - download) ANNEX 3 | Statistical Units (Download Data Service) (Department of Lands and Surveys)

Try to validate the metadata of this service, you will get this answer:

 

Inspire Validation Issues
 
  • The Get Download Service Metadata Response has validation issues

 and here are the issues:

Inspire Validation Issues
 
Expert documentation

 

It is an Atom feed which is totally defective: the URL of service metadata and the dataset metadata are placeholders which do not return anything:

-<feed xmlns="http://www.w3.org/2005/Atom" xmlns:georss="http://www.georss.org/georss"xmlns:inspire_dls="http://inspire.ec.europa.eu/schemas/inspire_dls/1.0" xml:lang="en">

-<title>
Buildings
</title>
-<subtitle>
Buildings
</subtitle>
<link href="http://servername/geoportal/rest/document?id={5A0A943B-D6AE-403D-886B-B02944D0E4B3}"rel="describedby" type="application/xml" />
<linkhref="http://pgis02.govcy.intranet:6080/arcgis/rest/directories/arcgisforinspire/INSPIRE/SU_StatisticalUnits_MapServer/serviceatoma1.xml"hreflang="en" rel="self" title="This document" type="application/atom+xml" />
<link href="opensearchdescriptiona1.xml" hreflang="en" rel="search" title="Open Search Description"type="application/opensearchdescription+xml" />
-<rights>
Copyright (c) 2015, XYZ; all rights reserved
</rights>
-<updated>
2012-03-31T13:45:03Z
</updated>
-<author>
-<name>
FirstName LastName
</name>
-<email>
doe@xyz.org
</email>
 
</author>
-<entry>
-<inspire_dls:spatial_dataset_identifier_code>
waternetwork
</inspire_dls:spatial_dataset_identifier_code>
-<inspire_dls:spatial_dataset_identifier_namespace> </inspire_dls:spatial_dataset_identifier_namespace>
<link href="http://servername/geoportal/rest/document?id={5A0A943B-D6AE-403D-886B-B02944D0E4B3}"rel="describedby" type="application/xml" />

 

Best regards,

Angelo 

#20 Updated by Antonis Papantoniou about 2 years ago

Dear Angelo,

Thank you for your feedback. We have made some changes on the Habitats and Biotopes Service atom file. Could you validate please.

Is there a way that i can perform the same checks as you do in order to validate my changes before contactign you?

Thanks,

Antonis

#21 Updated by Angelo Quaglia about 2 years ago

Comment Edit

Dear Antonis,

there are still very serious problems with that Download Service.

For example, the link to the service metadat is still wrong.

<title>Buildings</title>
<subtitle>Buildings</subtitle>
<link href="http://servername/geoportal/rest/document?id={5A0A943B-D6AE-403D-886B-B02944D0E4B3}" rel="describedby" type="application/xml"/>

 

You can validate INSPIRE Network Services with the Validator 2:

http://inspire-geoportal.ec.europa.eu/validator2/

 

You get:

Best regards,
Angelo

#22 Updated by Antonis Papantoniou about 2 years ago

I have made changes to Habitats and Biotopes Download Service, not Statistical units yet. I am working on this.

Please validate Habitats and Biotopes Download Service.

Thanks

 

#23 Updated by Angelo Quaglia about 2 years ago

Ah, OK, sorry, but could you perhaps validate it yourself and write here the URL of the validation report?

#24 Updated by Antonis Papantoniou about 2 years ago

Regarding the Habitats and Biotopes, just to clarify,  we have made changes in the service atom xml in order to correct the urls and ids. We have included only one of the two datasets (Department of Envronment) for the moment, just to verify that the structure of the service atom xml is correct. 

the ulr we have used to produce the report is:

http://weba.dls.moi.gov.cy/arcgis/rest/directories/arcgisforinspire/INSPIRE/HB_HabitatBiotop_MapServer/serviceatoma1.xml

The report provided via the inspire validator2 is:

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-5639aa1e-575b-11e8-9445-52540023a883_20180514-114403/#Summary%20of%20Download%20Services

 

Antonis

#26 Updated by Angelo Quaglia about 2 years ago

Regarding the Habitats and Biotopes

Great, this helps, thanks.

The service metadata is now fine, but the link to the dataset metadata is not:

If you click on the box labeled as "1", you see more details about the problem:

The issue is with this link: it must point to the dataset metadata not the service:

   <entry>

      <inspire_dls:spatial_dataset_identifier_code>%7B6BE2F8ED-18F8-4C65-95DD-7997473ADB09%7D</inspire_dls:spatial_dataset_identifier_code>
  
      <inspire_dls:spatial_dataset_identifier_namespace>http://www.esri.com/inspire/atom</inspire_dls:spatial_dataset_identifier_namespace> 

      <link href="http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7B6BE2F8ED-18F8-4C65-95DD-7997473ADB09%7D"
            rel="describedby"
            type="application/xml"/>

...

      <title>Habitats and Biotopes</title> 

 

http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id={6BE2F8ED-18F8-4C65-95DD-7997473ADB09}

<gmd:fileIdentifier>
<gco:CharacterString>{52B81654-4FBC-4639-96E8-07DDD5171198}</gco:CharacterString>
</gmd:fileIdentifier>
<gmd:language>
</gmd:language>
<gmd:hierarchyLevel>
<gmd:MD_ScopeCode codeSpace="ISOTC211/19115" codeList="http://www.isotc211.org/2005/resources/Codelist/gmxCodelists.xml#MD_ScopeCode" codeListValue="service">service</gmd:MD_ScopeCode>
</gmd:hierarchyLevel>

#27 Updated by Angelo Quaglia about 2 years ago

Same problem with the Statistical Units:

Inspire Validation Issues
 
Expert documentation

#28 Updated by Antonis Papantoniou about 2 years ago

Can you please validate the Statistical Units Download Service?

The report link is the below:

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-3aeef1c1-5778-11e8-9445-52540023a883_20180514-151053/

 

My question is how do i describe the two datasets in the opensearchdescription?

I have edited the <Query /> entry with one of the two datasets but i assume that i need to add both. How can  correct the below?

<Query 
count="1" 
inspire_dls:crs="http://www.opengis.net/def/crs/EPSG/0/4326" 
inspire_dls:spatial_dataset_identifier_code="%7B08718614-C0FB-4349-91DF-9E73D4E36FB0%7D"
inspire_dls:spatial_dataset_identifier_code="%7BD9121BE9-AF9E-4815-B82B-4CBBE644BCA6%7D" 
inspire_dls:spatial_dataset_identifier_namespace="http://moi.gov.cy" 
language="en" 
role="example" 
title="a4i"
/>

#29 Updated by Antonis Papantoniou about 2 years ago

Dear Angelo,

We have made several improvement changes on all xml files for Statistical Units. In order to validate the structure we have left only one entry in service atom file. 

The report link is:

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-f84c3d3c-581a-11e8-9445-52540023a883_20180515-103549/services/1/resourceLocator1/download/services/1/resourceReport/

We dont understand why in the below message

A link to the subfeed could not be found in the entry with title "ANNEX 3 | Statistical Units - Analysis and Statistics Office Cyprus Police (Metadata of Data)" or the link to it ("http://weba.dls.moi.gov.cy/arcgis/rest/directories/arcgisforinspire/INSPIRE/SU_StatisticalUnits_MapServer/datasetatoma1.xml%20http://weba.dls.moi.gov.cy/arcgis/rest/directories/arcgisforinspire/INSPIRE/SU_StatisticalUnits_MapServer/") could not be resolved successfully because of the following error: "Could not interpret document: "

the url appears twice.

Could you please validate and advice?

 

Thanks

#30 Updated by Angelo Quaglia about 2 years ago

Dear Antonis,

inspecting the top feed I see that inside the entry element, you have two rel="alternate" links to the dataset subfeed, the first one is good while the second does not point to an actual document:

<link href="http://weba.dls.moi.gov.cy/arcgis/rest/directories/arcgisforinspire/INSPIRE/SU_StatisticalUnits_MapServer/datasetatoma1.xml" hreflang="en"rel="alternate" title="dataset link" type="application/atom+xml" />
<link href="http://weba.dls.moi.gov.cy/arcgis/rest/directories/arcgisforinspire/INSPIRE/SU_StatisticalUnits_MapServer/" hreflang="en" rel="alternate"title="dataset link" type="application/atom+xml" />

What is the use of the second link

http://weba.dls.moi.gov.cy/arcgis/rest/directories/arcgisforinspire/INSPIRE/SU_StatisticalUnits_MapServer/

This is what that URL returns:

Page Not Found - /arcgis/rest/directories/arcgisforinspire/INSPIRE/SU_StatisticalUnits_MapServer/datasetatoma1.xml


Type: Status report

Message: /arcgis/rest/directories/arcgisforinspire/INSPIRE/SU_StatisticalUnits_MapServer/datasetatoma1.xml

Description: The requested resource (/arcgis/rest/directories/arcgisforinspire/INSPIRE/SU_StatisticalUnits_MapServer/datasetatoma1.xml) is not available.

 

#31 Updated by Antonis Papantoniou about 2 years ago

The reason for having two links is that we wanted to assist internet users, when they download the serviceatoma1.xml from our Geoportal Server, to be able to easily locate the datasetatoma1.xml that contains the GML files links.

We have commented out the second URL and left only the first one. Does this comply with the validation rules?

 

Regarding the Spatial Obejcts contained in dataset atom file, we noticed that:

The link examples no longer work, but 

http://inspire-registry.jrc.ec.europa.eu/registers/

has become

http://inspire.ec.europa.eu/registry

and in this registry there is an INSPIRE feature concept dictionary register so

http://inspire-registry.jrc.ec.europa.eu/registers/FCD/

becomes

http://inspire.ec.europa.eu/featureconcept/

and the full links become

http://inspire.ec.europa.eu/featureconcept/Watercourse

and 

http://inspire.ec.europa.eu/featureconcept/StandingWater

Could you advice if the corresponding link for Statistical Units Spatial Object link should be http://inspire.ec.europa.eu/featureconcept/StatisticalUnit ? Because we get the followng error:

Inside subfeed with id:"http://weba.dls.moi.gov.cy/arcgis/rest/directories/arcgisforinspire/INSPIRE/SU_StatisticalUnits_MapServer/datasetatoma1.xml", no Spatial Object Type has been declared

 

Antonis

 

 

 

#32 Updated by Angelo Quaglia about 2 years ago

Dear Antonis,

I understand the need to help the end users but that is not the proper way to do it as you are declaring 

 type="application/atom+xml"

while it is not what the URL returns.

You might want to have a look at this demo Atom service I created long ago to exemplify a user friendly implementation:

You even get a smart code viewer to see how I implemented it:

 

 

 

About the Spatial Object Types, you are right, many things have changed with the Registry since the Atom implementation was defined.

Let me check and I will come back to you shortly (after lunch, probably).

Best regards,
Angelo

 

 

 

#33 Updated by Angelo Quaglia about 2 years ago

Correction:

I already modified the code to support notation that sometime ago.

Let me test what is really happening.

Yes, that piece of code needs to be touched one more time and some people still think HTTP URIs are a good idea.

I will therefore support also these URIs:

http://inspire.ec.europa.eu/featureconcept/<SpatialObjectTypeName>

for example:

http://inspire.ec.europa.eu/featureconcept/StatisticalUnit 

I expect to be able to deploy the new version this week.

Best regards,

Angelo

 

#35 Updated by Angelo Quaglia about 2 years ago

This does not make sense:

http://inspire.ec.europa.eu/theme/<SpatialObjectTypeName>

This location:

http://inspire.ec.europa.eu/theme/

contains the list of INSPIRE Spatial Data Themes, like Addresses, Cadastral Parcels, etc/

 

Each Spatial Data Theme comprises different Spatial Object Types, for example:

The Addresses Theme contains these Spatial Object Types:

<xs:enumeration value="AddressAreaName"/>
<xs:enumeration value="AddressComponent"/>
<xs:enumeration value="AdminUnitName"/>
<xs:enumeration value="PostalDescriptor"/>
<xs:enumeration value="ThoroughfareName">
 
while the Cadastral Parcels Theme comprises these other Spatial Object Types:
<xs:enumeration value="BasicPropertyUnit">
<xs:enumeration value="CadastralBoundary"/>
<xs:enumeration value="CadastralParcel"/>
<xs:enumeration value="CadastralZoning">
 
 
 

#36 Updated by Angelo Quaglia about 2 years ago

The Theme Statistical Units comprises the following Spatial Object Types:

<xs:enumeration value="StatisticalUnit"/>
<xs:enumeration value="StatisticalGrid"/>
<xs:enumeration value="StatisticalGridCell"/>
<xs:enumeration value="AreaStatisticalUnit"/>
<xs:enumeration value="StatisticalTessellation"/>
<xs:enumeration value="VectorStatisticalUnit"/>
<xs:enumeration value="Evolution"/>
<xs:enumeration value="NUTSRegion"/>
 
This is the link I find in your dataset feed:
<link href="http://inspire.ec.europa.eu/theme/su" hreflang="en" rel="describedby" title="title" type="text/html"/>
 
http://inspire.ec.europa.eu/theme/su is a Spatial Data Theme, not a Spatial Object Type.
 
 
 
 
 

#37 Updated by Antonis Papantoniou about 2 years ago

I was editing the xml for testing purposes. now you should get http://inspire.ec.europa.eu/featureconcept/StatisticalUnit

Based on all the changes we did on Statistical Units Download Service so far, is there anything left we need to improve? It would be very helpfull for us to validate one Download Service without any issues and then proceed with improving the rest of the Download Services.

Could you please advice regarding the Statistical Units?

 

#38 Updated by Angelo Quaglia about 2 years ago

That is a very sound approach.

I suggest you use the INSPIRE Geoportal Validator 2 ( http://inspire-geoportal.ec.europa.eu/validator2/ ) .

Then, you can post here the URL of the validation report so that I can have a look at it.

 

 

 

#39 Updated by Antonis Papantoniou about 2 years ago

Below is the validator report for Statistical Units after republishing the Download Service and applying the latest Service, Dataset and OpenSearchDescription xml files.

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-b5c39811-5837-11e8-9445-52540023a883_20180515-140133/services/1/resourceLocator1/download/services/1/resourceReport/

Could you review the report and advice accordingly

#40 Updated by Angelo Quaglia about 2 years ago

Thank you.

I see that the error about the missing Spatial Object Type is still there.

I will therefore see what happens in my development instance.

#41 Updated by Angelo Quaglia about 2 years ago

Ah, I see now.

Statistical Units is an Annex III theme, so I haven't included it in the Spatial Object Type list, yet .

The deadline will expire in 21/10/2020 

You can safely ignore the error for the moment.

I am now adding them, anyway, and they will be available with the next deployment of the INSPIRE Geoportal.

 

 

 

#42 Updated by Angelo Quaglia about 2 years ago

Dear Antonis,

I was looking at the schema definitions of the Spatial Object Types.

StatisticalUnit is an abstract object type, which means that you cannot instantiate objects of that type.

I then downloaded the data file from your service and found concrete objects, like AreaStatisticalUnit

You need to declare Spatial Object Types actually present in the dataset file, not abstract ones.

Best regards,

Angelo

#43 Updated by Antonis Papantoniou about 2 years ago

Hello Angelo,

I made the change in the dataset atom feed and changed the url of the spatial obect to AreaStatisticalUnit. I still receive the error

Inside subfeed with id:"http://weba.dls.moi.gov.cy/arcgis/rest/directories/arcgisforinspire/INSPIRE/SU_StatisticalUnits_MapServer/datasetatoma1.xml", no Spatial Object Type has been declared

Below is the report url

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-b3845d8d-58d3-11e8-9445-52540023a883_20180516-083810/services/1/resourceLocator1/download/services/1/resourceReport/

The data file you downloaded, you mean the gml?

In case there are more than one spatial object types identified in the data, do i need to add corresponding records for each spatial object type in the dataset atom xml under the previous one?

 

Antonis

#44 Updated by Angelo Quaglia about 2 years ago

Hi Rene,

- yes, you are still getting the error message because, as I wrote above:

Statistical Units is an Annex III theme, so I haven't included it in the Spatial Object Type list, yet .

The deadline will expire in 21/10/2020 

You can safely ignore the error for the moment.

I am now adding them, anyway, and they will be available with the next deployment of the INSPIRE Geoportal.

 

- yes, the data file is the gml file containing the Spatial Objects:

<?xml version="1.0" encoding="UTF-8"?>

<gml:FeatureCollection>

...

       <gml:featureMember>

             <su-vector:AreaStatisticalUnit gml:id="id1feb56df-478a-4593-b141-43536eb6e7dc">

                    <su-vector:inspireId>

- yes, you need to add one link for each Spatial Object Type, instances  of which are present in the gml file

 
 

 

Best regards,

Angelo

 

#45 Updated by Antonis Papantoniou about 2 years ago

Thank you Angelo for your feedback. I have added the extra entry for the second spatial object type.

The new report is below

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-ffbff71c-58dc-11e8-9445-52540023a883_20180516-094444/services/1/resourceLocator1/download/services/1/resourceReport/

 

Antonis

#46 Updated by Angelo Quaglia about 2 years ago

It really looks great, congratulations.

Just one thing:

why are you declaring the the media type of the file is

application/x-filegdb

while the downloaded file contains gml?

application/gml+xml

 

Angelo

#47 Updated by Antonis Papantoniou about 2 years ago

Thank you Angelo.

 

I have corrected the value. I assume then that, with this last improvement, this specific Download Service is ok now and we dont need to take any further action.

Could you please confirm? If this download Service does not require any further actions from our side for the moment, then we can proceed editing the xml files and improving the rest of the Predefined Download Services (Annex III).

The latest report for Statistical Units Download Service is below

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-6e559afe-58e1-11e8-9445-52540023a883_20180516-101627/

Regards,

Antonis

#48 Updated by Angelo Quaglia about 2 years ago

Dear Antonis,

I see two things:

 

1) The bounding box in the dataset subfeed entries is not correct:

 

2) instead of 

Conditions Applying To Access And Use
Free of charge

Limitations On Public Access
Free of charge

 

I would write:

Conditions Applying To Access And Use
no conditions apply

Limitations On Public Access
no limitations

 

Best regards,

Angelo

#49 Updated by Antonis Papantoniou about 2 years ago

Dear Angelo,

Regarding the bounding box, you are referring to the line:

<georss:polygon>bounding box coordinates</georss:polygon>

which exist under each entry feed of the dataset xml?

Edited record is:

<georss:polygon>35.9027 32.0382 35.9027 34.8856 34.2783 34.8856 34.2783 32.0382 35.9027 32.0382</georss:polygon>

 

Regarding the values of Conditions Applying To Access And Use and Limitations On Public Access

i have changed these in the metadata documents. could you verify please?

 

Thanks

Antonis

#50 Updated by Angelo Quaglia about 2 years ago

Dear Antonis,

the element I am referring to is in the service top feed, inside each entry.

<feed xmlns="http://www.w3.org/2005/Atom" xmlns:georss="http://www.georss.org/georss" xmlns:inspire_dls="http://inspire.ec.europa.eu/schemas/inspire_dls/1.0" xml:lang="en">
<title>Statistical Units</title>
...
<entry>
<title>Statistical Units - Analysis and Statistics Office Cyprus Police</title> 
...  
<georss:polygon>47.202 5.755 55.183 5.755 55.183 15.253 47.202 15.253 47.202 5.755</georss:polygon>

<category label="ETRS89" term="http://www.opengis.net/def/crs/EPSG/0/4258"/>
</entry>
...

<georss:polygon>47.202 5.755 55.183 5.755 55.183 15.253 47.202 15.253 47.202 5.755</georss:polygon>

 

It should be instead, if I get the desired bounding box right:

<georss:polygon>34.5043  32.0945 35.2713  32.0945 35.2713 34.2038 34.5043 34.2038 34.5043 32.0945</georss:polygon>

 

 

 

    N               W
  35.2713       32.0945
        N          E
  35.2713  34.2038 
     
    S              W
 34.5043      32.0945
       S            E
  34.5043   34.2038   

 

Best regards,

Angelo

 

 

#51 Updated by Antonis Papantoniou about 2 years ago

Dear Angelo,

I have made the correction in the service top feed for Statistical Units. Below is the updated report

 

http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-c25c18a7-5ced-11e8-828b-52540023a883_20180521-135447/

 

Antonis

#52 Updated by Antonis Papantoniou about 2 years ago

Dear Angelo,

Could you review the latest report and advice if we need to take further action for Statistical Units, or if it considered a successfull implemented Service?

Thanks,

Antonis

#53 Updated by Angelo Quaglia about 2 years ago

Dear Antonis,

it really looks very good.

However, I cannot give you an "official stamp" of conformity as the INSPIRE Geoportal is offered on a "best effort" basis.

The software is continuously improved, so there might be issues that are still going undetected for the time being.

In addition, Technical Guidance documents undergo corrections, updates, evolutions so, what is correct today, might not be in the future.

Having said that, you are offering great functionality.

Best regards,

Angelo

 

 

#54 Updated by Antonis Papantoniou about 2 years ago

Dear Angelo,

 

Could you perform a new harvesting on Cyprus Services as we have performed several improvment changes and we would like to see the updated Country report. 

Thanks,

Antonis

#55 Updated by Angelo Quaglia about 2 years ago

Dear Antonis,

a new harvesting has just completed.

Best regards,

Angelo

 

#56 Updated by Antonis Papantoniou about 2 years ago

Dear Angelo,

We have validated all the Metadata URLS for Statistical Units and deployed all necessary changes/improvements. Below are the latest validator2 reports we have collected:

View metadata http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-6dd9e8b2-6af1-11e8-ad5e-52540023a883_20180608-095619/ http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7BFC734D49-7F2B-4FA1-A983-3BA74B3B13A3%7D
Download metadata http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-800c34ab-6e51-11e8-96fc-52540023a883_20180612-170135/ http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7B8846102B-63AF-4D79-B4C4-79B1BA6E827F%7D
Data metadata http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-b18f2bc7-6af2-11e8-ad5e-52540023a883_20180608-100522/datasets/1/resourceReport/ http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7BD9121BE9-AF9E-4815-B82B-4CBBE644BCA6%7D
Data metadata http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-d471fcfe-6af2-11e8-ad5e-52540023a883_20180608-100621/datasets/1/resourceReport/ http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7B08718614-C0FB-4349-91DF-9E73D4E36FB0%7D
Download service http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-72a3cef4-6f98-11e8-b649-52540023a883_20180614-080158/ http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7B8846102B-63AF-4D79-B4C4-79B1BA6E827F%7D
View service http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-9a933053-6af1-11e8-ad5e-52540023a883_20180608-095734/

http://weba.dls.moi.gov.cy/arcgis/rest/services/INSPIRE/SU_StatisticalUnits/MapServer/exts/InspireView/service?VERSION=1.3.0&SERVICE=wms&REQUEST=getCapabilities

 

Accorting to our findings during our effort to improve Statistical Units, we have proceeded with the rest of the Data Themes.

Statistical Units, according to the latest validator2 reports we have collected, seem ok now. Could you please verify the above and advice?

In order to avoid reporting issues for several other Data Themes in this issue, if Statistical Units can be considered as Compliant now, we could proceed closing this issue and for any other Data Themes, we can post new issues per data theme.

Please advice on the above. 

 

Thanks

#57 Updated by Antonis Papantoniou about 2 years ago

Dear Angelo,

We have validated all the Metadata URLS for Statistical Units and deployed all necessary changes/improvements. Below are the latest validator2 reports we have collected:

View metadata http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-6dd9e8b2-6af1-11e8-ad5e-52540023a883_20180608-095619/ http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7BFC734D49-7F2B-4FA1-A983-3BA74B3B13A3%7D
Download metadata http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-800c34ab-6e51-11e8-96fc-52540023a883_20180612-170135/ http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7B8846102B-63AF-4D79-B4C4-79B1BA6E827F%7D
Data metadata http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-b18f2bc7-6af2-11e8-ad5e-52540023a883_20180608-100522/datasets/1/resourceReport/ http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7BD9121BE9-AF9E-4815-B82B-4CBBE644BCA6%7D
Data metadata http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-d471fcfe-6af2-11e8-ad5e-52540023a883_20180608-100621/datasets/1/resourceReport/ http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7B08718614-C0FB-4349-91DF-9E73D4E36FB0%7D
Download service http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-72a3cef4-6f98-11e8-b649-52540023a883_20180614-080158/ http://eservices.dls.moi.gov.cy/geoportal_inspire/rest/document?id=%7B8846102B-63AF-4D79-B4C4-79B1BA6E827F%7D
View service http://inspire-geoportal.ec.europa.eu/resources/sandbox/INSPIRE-9a933053-6af1-11e8-ad5e-52540023a883_20180608-095734/

http://weba.dls.moi.gov.cy/arcgis/rest/services/INSPIRE/SU_StatisticalUnits/MapServer/exts/InspireView/service?VERSION=1.3.0&SERVICE=wms&REQUEST=getCapabilities

 

Accorting to our findings during our effort to improve Statistical Units, we have proceeded with the rest of the Data Themes.

Statistical Units, according to the latest validator2 reports we have collected, seem ok now. Could you please verify the above and advice?

In order to avoid reporting issues for several other Data Themes in this issue, if Statistical Units can be considered as Compliant now, we could proceed closing this issue and for any other Data Themes, we can post new issues per data theme.

Please advice on the above. 

 

Thanks

Also available in: Atom PDF