Support #3165

SI: Metadata from Inspire (SI) not available at Inspire geoportal

Added by Martin Puhar over 2 years ago. Updated over 2 years ago.

Status:ResolvedStart date:26 Mar 2018
Priority:NormalDue date:
Assignee:Angelo Quaglia% Done:

0%

Category:Harvesting process
Target version:-
Submitting Organisation:SI Knowledge-Base relevant?:
Proactive:No Keyword #1:
Country:SI - Slovenia Keyword #2:
Originating UI:Resource Browser Keyword #3:

Description

Dear Angelo, 

 

we have noticed that metadata from Inspire (SI) are not available at the Inspire geoportal (Discovery/Viewer and Resource browser).

The CSW service is working OK (http://prostor4.gov.si/imps/srv/eng/csw-INSPIRE?SERVICE=CSW&VERSION=2.0.2&REQUEST=GetCapabilities).

Is there any other problem during harvesting?

 

Thanks for your help.

 

Martin

History

#1 Updated by Angelo Quaglia over 2 years ago

  • Category set to Harvesting process
  • Status changed from New to Feedback
  • Assignee set to Angelo Quaglia
  • Submitting Organisation set to SI
  • Country set to SI - Slovenia
  • Originating UI set to Resource Browser

Dear Martin,

it is fixed, now.

Many thanks for reporting this.

The Discovery Service has just been successfully reharvested but I noticed that due to the increased load to the system, a timeout caused an error which makes the INSPIRE Geoportal believe something went wrong with the new harvesting.

I am addressing the problem in the code.

Best regards,

Angelo

 

#2 Updated by Angelo Quaglia over 2 years ago

Yes, I can confirm you that the problem has been a timeout while deleting the results of the previous harvesting:

26 Mar 2018 13:35:52,714 (PullProcessor.java:1829) -  
ERROR Thread-97775 eu.europa.ec.inspire.resource.discovery.PullProcessor - 
Solr could not cache document "[stream.body=<?xml version="1.0" encoding="UTF-8"?><delete><query>id:\/INSPIRE-6f0cd439-226d-11e6-9ff2-52540023a883_20180326-131906*</query></delete>]" 
because of the following error: "Read timed out"
eu.europa.ec.inspire.geoportal.exception.CachingFailedException: 
Solr could not cache document "[stream.body=<?xml version="1.0" encoding="UTF-8"?><delete><query>id:\/INSPIRE-6f0cd439-226d-11e6-9ff2-52540023a883_20180326-131906*</query></delete>]"
 because of the following error: "Read timed out"

Despite the timeout, the deletion was carried out.

However, the error made the INSPIRE Geoportal believe something had gone wrong with the new harvesting and, as a result, it removed also the latest results.

 

Angelo

 

#3 Updated by Martin Puhar over 2 years ago

Dear Angelo,

 

thank you for your quick response.

 

Regards,

 

Martin

#4 Updated by Angelo Quaglia over 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF