Support #3208

DK: ETF Validator - Docker deployment

Added by Angelo Quaglia over 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:19 Apr 2018
Priority:NormalDue date:
Assignee:Roberto Sgnaolin% Done:

0%

Category:ETF Validator
Target version:-
Submitting Organisation:DK Knowledge-Base relevant?:
Proactive:No Keyword #1:
Country:DK - Denmark Keyword #2:
Originating UI: Keyword #3:

Description

From: Lars Næsbye Christensen [lanch@sdfe.dk]
Sent: 19 April 2018 05:47
To: QUAGLIA Angelo (JRC-ISPRA-EXT)
Subject: Problems with deploying the ETF validator
 
 

Dear Angelo Quaglia,

 

I am trying to implement the ETF webapp for the Agency for Data Supply and Efficiency in Denmark, and I've run into some problems. I got your contact information from Lars Erik Storgaard .

 

The problem is that when I run it as Docker image I can make it work fine in one environment but not the other. I use the command

 

sudo docker run --name etf -d -p 8082:8080 -v ~/etf:/etf iide/etf-webapp:latest (we access eft on port 8082 through HAproxy)

 

This pulls the app fine from the docker image hub and runs it. It runs correctly in our test environment but not in production, and in production I get a different error when accessing the top level (one level up from /etf-webapp ).

 

In test, I get :

 

No context on this server matched or handled this request.

Contexts known to this server are:

/etf-webapp ---> o.e.j.w.WebAppContext@4520ebad{/etf-webapp,[file:///tmp/jetty/jetty-0.0.0.0-8080-etf-webapp.war-_etf-webapp-any-6061467880627406135.dir/webapp/, jar:file:///tmp/jetty/jetty-0.0.0.0-8080-etf-webapp.war-_etf-webapp-any-6061467880627406135.dir/webapp/WEB-INF/lib/springfox-swagger-ui-2.6.1.jar!/META-INF/resources],AVAILABLE}{/etf-webapp.war}

 

And in production:

 

No context on this server matched or handled this request.

Contexts known to this server are:

/etf-webapp ---> o.e.j.w.WebAppContext@4520ebad{/etf-webapp,[file:///tmp/jetty/jetty-0.0.0.0-8080-etf-webapp.war-_etf-webapp-any-7995283481129842187.dir/webapp/, jar:file:///tmp/jetty/jetty-0.0.0.0-8080-etf-webapp.war-_etf-webapp-any-7995283481129842187.dir/webapp/WEB-INF/lib/springfox-swagger-ui-2.6.1.jar!/META-INF/resources],UNAVAILABLE}{/etf-webapp.war}

 

Both servers run the same OS and are on the same subnet, and I get no errors during the Docker commands. One is virtual and one is physical but this I suppose makes no difference to Docker.

 

Do you have an idea what might be the cause for this difference? It would be a great help if you could point me in the right direction.

 

 

Kind regards

Lars Næsbye Christensen

History

#1 Updated by Angelo Quaglia over 2 years ago

Dear Lars,

I am currently not dealing with the ETF validator, which is being developed by external companies.

I pass on this one to my coordinator Roberto who will dispatch it to the correct contacts.

 

Best regards,
Angelo

#2 Updated by Lars Næsbye Christensen over 2 years ago

I managed to fix it by asking on GitHub: https://github.com/etf-validator/etf-webapp/issues/150 

So I'm sorry for having bothered you, this issue has been solved through configuration changes until the bug has been fixed.

Regards,

Lars

#3 Updated by Angelo Quaglia over 2 years ago

  • Status changed from Assigned to Resolved

Dear Lars,

I am sorry I could not be of more help on this one.

Many thanks for reporting back.

Best regards,

Angelo

#4 Updated by Roberto Sgnaolin about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF