Support #3377

CZ: Czech metadata catalogue harvest

Added by Angelo Quaglia almost 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:23 May 2018
Priority:NormalDue date:
Assignee:Angelo Quaglia% Done:

0%

Category:Harvesting process
Target version:-
Submitting Organisation:CZ Knowledge-Base relevant?:
Proactive:No Keyword #1:
Country:CZ - Czech Republic Keyword #2:
Originating UI: Keyword #3:

Description

Dear Lenka,

Since the 22nd, the INSPIRE Geoportal has been unable to harvest your Discovery Service:

26 Sep 2018 16:43:59,881  INFO [main] (CSW.java:358) - Attempt n. 1
26 Sep 2018 16:43:59,881  INFO [main] (CSW.java:369) - Timeout set to  ms: 10100
26 Sep 2018 16:43:59,882  INFO [main] (CSWRequestGetRecords.java:213) - <csw:GetRecords xmlns:csw="http://www.opengis.net/cat/csw/2.0.2" xmlns:ogc="http://www.opengis.net/ogc" xmlns:gmd="http://www.isotc211.org/2005/gmd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:apiso="http://www.opengis.net/cat/csw/apiso/1.0" service="CSW" version="2.0.2"  maxRecords="1"  startPosition="1"  resultType="results" outputSchema="http://www.isotc211.org/2005/gmd" outputFormat="application/xml"> <csw:Query typeNames="gmd:MD_Metadata"> <csw:ElementSetName>full</csw:ElementSetName>    <ogc:SortBy>
      <ogc:SortProperty>
        <ogc:PropertyName>apiso:Identifier</ogc:PropertyName>
        <ogc:SortOrder>ASC</ogc:SortOrder>
      </ogc:SortProperty>
    </ogc:SortBy>  </csw:Query></csw:GetRecords>
26 Sep 2018 16:43:59,882 DEBUG [main] (OGCSRequest.java:535) - query String: null
26 Sep 2018 16:43:59,883 DEBUG [main] (OGCSRequest.java:543) - new URL with query : http://geoportal.gov.cz/php/micka/inspire/index.php
26 Sep 2018 16:43:59,883  INFO [main] (OGCSRequest.java:549) - built request URL: http://geoportal.gov.cz/php/micka/inspire/index.php
26 Sep 2018 16:43:59,885 DEBUG [main] (Locator.java:1383) - Timeout set to  ms: 10100
26 Sep 2018 16:44:00,134 DEBUG [main] (Locator.java:1347) - RequestPOST http://geoportal.gov.cz/php/micka/inspire/index.php HTTP/1.1
26 Sep 2018 16:44:00,134 DEBUG [main] (Locator.java:1348) - ResponseHttpResponseProxy{HTTP/1.1 500 Internal Server Error [Date: Wed, 26 Sep 2018 14:43:58 GMT, Server: Apache, Cache-Control: max-age=7200, public, must-revalidate, Expires: Wed, 26 Sep 2018 16:43:58 GMT, Content-Length: 0, Content-Type: text/html; charset=UTF-8, Set-Cookie: ROUTEID=.ms1; path=/, Set-Cookie: BCIDSLB=PS2ISP_U-SCI-59; domain=gov.cz; path=/; HttpOnly, Connection: close] [Content-Type: text/html; charset=UTF-8,Content-Length: 0,Chunked: false]}
26 Sep 2018 16:44:00,135 DEBUG [main] (Locator.java:1587) - Internal Server Error
26 Sep 2018 16:44:00,136 DEBUG [main] (Locator.java:2041) - The server at "http://geoportal.gov.cz/php/micka/inspire/index.php" refused the connection for the following reason: "No stream in response"
26 Sep 2018 16:44:00,137  INFO [main] (CSW.java:378) - Error on getRecords request: HTTP connection failed at url: "http://geoportal.gov.cz/php/micka/inspire/index.php" because No stream in response

 

 

Best regards,
Angelo

 

 


Related issues

Copied from Geoportal Helpdesk - Support #3269: CZ: Czech metadata catalogue harvest Feedback 23 May 2018

History

#1 Updated by Angelo Quaglia almost 2 years ago

Dear Lenka,

the issue is back,

The interaction with the remote service at "http://geoportal.gov.cz/php/micka/inspire/?service=csw&version=2.0.2&request=GetCapabilities" ended with the following error "HTTP connection failed at url: "http://geoportal.gov.cz/php/micka/inspire/index.php" because No stream in response" 

For the following groups, critical errors were encountered

 

 

Best regards,
Angelo

#2 Updated by Angelo Quaglia almost 2 years ago

After several attempts, the INSPIRE Geoportal has finally managed to get a clean harvest.

Kind regards,

Angelo

#3 Updated by Lenka Rejentova almost 2 years ago

  • Status changed from Feedback to Closed

Dear Angelo,

we finaly repair error on one of the servers so now CSW should harvest as usually.

Thank you

Lenka

#4 Updated by Angelo Quaglia almost 2 years ago

Dear Lenka,

many thanks for your feedback.

Best regards,

Angelo

Also available in: Atom PDF