Support #3737

NL: feedback calculation indicators

Added by Ine de Visser 11 months ago. Updated 10 months ago.

Status:FeedbackStart date:12 Nov 2019
Priority:NormalDue date:
Assignee:Davide Artasensi% Done:

0%

Category:Harvesting results
Target version:-
Submitting Organisation:NL Knowledge-Base relevant?:No
Proactive:No Keyword #1:indicators
Country:NL - The Netherlands Keyword #2:
Originating UI: Keyword #3:

Description

Dear INSPIRE team, 

I have also troubles with the calculation of DSi1.5, (the number of metadata with a keyword for national territory)The  result is zero, at this moment, the discovery service it contains 104 datasets with this keyword, added following the instructions. I suppose most dataproviders are providing this keyword via an anchor. We harvested last saturday again, the problem is still there.

It's not yet possible to check the calculation of the metadata indicators, but will the geoportal support the use of anchors on several metadata elements? I know see in the overview of datasets with issues, before publishing, that responsible organisations are empty in this overview when an anhor is used.

 

Calculation of DSi2 seems not correct. This can’t be an higher percentage then the highest of DSi2.1 or DSi2.2 or DSi2.3. DSi2 looks like a sum of DSi2.1+DSi2.2+DSi2.3. Or is the DSi2 value replaced with the value of NSi2? In my results they are exactly the same.

 

After publishing the harvest results, closing the website and reopening it, it’s not possible to check the monitoring indicators anymore. Check last report is pointing to the sandbox environment

 

Download indicator reports does not work in IE.

 

Best regards Ine

 

 

 

 

History

#1 Updated by Daniele Francioli 11 months ago

  • Status changed from New to Assigned
  • Assignee set to Davide Artasensi

#2 Updated by Davide Artasensi 11 months ago

  • Assignee deleted (Davide Artasensi)
  • Submitting Organisation set to NL
  • Country set to NL - The Netherlands

Dear Ine,

 

I will try to reply inline for each of your statements (quoted).

I have also troubles with the calculation of DSi1.5, (the number of metadata with a keyword for national territory)The  result is zero, at this moment, the discovery service it contains 104 datasets with this keyword, added following the instructions. I suppose most dataproviders are providing this keyword via an anchor. We harvested last saturday again, the problem is still there.

It's not yet possible to check the calculation of the metadata indicators, but will the geoportal support the use of anchors on several metadata elements? I know see in the overview of datasets with issues, before publishing, that responsible organisations are empty in this overview when an anhor is used.

Could you please help us by providing with some ids of the ones you mentioned tagged with the new "national" keyword?

About the anchors, it should work, but still if you can provide a specific case, we can have a look.

Calculation of DSi2 seems not correct. This can’t be an higher percentage then the highest of DSi2.1 or DSi2.2 or DSi2.3. DSi2 looks like a sum of DSi2.1+DSi2.2+DSi2.3. Or is the DSi2 value replaced with the value of NSi2? In my results they are exactly the same.

DSi2.x indicators belong to distinct subsets (each one based on a specific annex) of the more "broader" set of DSi2, that include every MD declared as "conformant" to 1089/2010.

Therefore the latter (DSi2) could be higher than the highest of the others, and since these MD elements could be members of multiple annex set (A ∩ B), it should not be a sum.

Please, could you further explain me your hypothesis of a correlation with NSi2? (which is based purely on the view and downloadable aspects)

 

Let's run this simulation of a real world scenario.

A total of 5 dataset metadata are declared as follow:

- MD [A] has theme keywords belonging to Annex I and II, declared conformant to 1089/2010

- MD [B] has theme keywords belonging to Annex II, declared conformant to 1089/2010

- MD [C] has theme keywords belonging to Annex I and III, declared conformant to 1089/2010

- MD [D] and

- MD [E] have no theme keywords specified (note: against MD v2.0 TG Req 1.4) therefore they should not be declared conformant

 

DSi1.1 will be 5, and therefore DSi2 will be 60% (3/5), DSi2.1 will be 40% (2/5), DSi2.2 will be 40% (2/5), and DSi2.3 will be 20% (1/5)

Moreover, in this case DSi2 highlights the incomplete coverage of MDs declared conformant.

 

After publishing the harvest results, closing the website and reopening it, it’s not possible to check the monitoring indicators anymore. Check last report is pointing to the sandbox environment

Thanks for the feedback. I will add this suggestion in our internal product backlog.

Download indicator reports does not work in IE.

We didn't encounter this bug yet. Could you please indicate which version of IE you tested?

 

Best regards,

Davide on behalf of the JRC INSPIRE Support team

#3 Updated by Davide Artasensi 10 months ago

  • Assignee set to Davide Artasensi

#4 Updated by Daniela Hogrebe 10 months ago

Dear Davide,

I have a different understanding regarding the calculation of the DSi2 indicators. Using your example the indicators from my point of view would be:

DSi2 = 60% (3/5 = sum of all data sets)

DSi2.1 = 100% (2/2 = sum of Annex I data sets)

DSi2.2 = 100% (2/2 = sum of Annex II data sets)

DSi2.3 = 100% (1/1 = sum of Annex III data sets)

Best regards,

Daniela

#5 Updated by Erik Obersteiner 10 months ago

I fully support Danielas calculation - I think thats the way we did it the years before and how it is stated in the legal text.

Best Erik

#6 Updated by Davide Artasensi 10 months ago

Dear Daniela and Erik,

you are right about the data source of the divisor for DSi2(.1/.2 /.3).

For instance, for DSi2.1 should be:

The number of spatial data sets corresponding to the themes listed in Annex I to Directive 2007/2/EC which are in conformity with Regulation (EU) No 1089/2010 multiplied by a hundred and divided by the number of spatial data sets corresponding to the themes listed in that Annex.

I will update immediately the code so it will calculate them as you correctly exposed.

To all, many thanks for your feedback, bringing it up for discussion and clarification.

Kind regards,

Davide on behalf of the JRC INSPIRE Support team

#7 Updated by Davide Artasensi 10 months ago

  • Status changed from Assigned to Resolved

Dear all,

we published a new release of the HarvestConsole containing this fix.

 

Best regards,

Davide

#8 Updated by Ine de Visser 10 months ago

  • Status changed from Resolved to Feedback

Dear all, thanx for the reactions on this issue! I was to busy to follow...

Based on the harvesting from last monday, where this issue is fixed, i still see some weird things in the calcualtion of DSi 2.2. (the easiest to control of the DSi2 indicators, because of the low number of datasets).

The 50% we got here is to high. We have 26 datasest in annex II, 6 of them declared to be conformand with  VERORDENING (EU) Nr. 1089/2010 VAN DE COMMISSIE van 23 november 2010. In my opinion DSi2.2 should be 6/26 = 23 %

In some metadata records there is conformance declared to other specifications, fi in the metadata record with fileidentifier 74aca3eb-c38b-4214-9537-e0abc69e11b5;

    <gmd:report>
        <gmd:DQ_DomainConsistency>
          <gmd:result>
            <gmd:DQ_ConformanceResult>
              <gmd:specification>
                <gmd:CI_Citation>
                  <gmd:title>
                    <gco:CharacterString>VERORDENING (EU) Nr. 1089/2010 VAN DE COMMISSIE van 23 november 2010 ter uitvoering van Richtlijn 2007/2/EG van het Europees Parlement en de Raad betreffende de interoperabiliteit van verzamelingen ruimtelijke gegevens en van diensten met betrekking tot ruimtelijke gegevens</gco:CharacterString>
                  </gmd:title>
                  <gmd:alternateTitle>
                    <gco:CharacterString>INSPIRE</gco:CharacterString>
                  </gmd:alternateTitle>
                  <gmd:date>
                    <gmd:CI_Date>
                      <gmd:date>
                        <gco:Date>2010-12-08</gco:Date>
                      </gmd:date>
                      <gmd:dateType>
                        <gmd:CI_DateTypeCode codeListValue="publication" codeList="http://www.isotc211.org/2005/resources/codeList.xml#CI_DateTypeCode"/>
                      </gmd:dateType>
                    </gmd:CI_Date>
                  </gmd:date>
                </gmd:CI_Citation>
              </gmd:specification>
              <gmd:explanation>
                <gco:CharacterString>Data conform specificatie</gco:CharacterString>
              </gmd:explanation>
              <gmd:pass>
                <gco:Boolean>false</gco:Boolean>
              </gmd:pass>
            </gmd:DQ_ConformanceResult>
          </gmd:result>
        </gmd:DQ_DomainConsistency>
      </gmd:report>
      <gmd:report>
        <gmd:DQ_DomainConsistency>
          <gmd:result>
            <gmd:DQ_ConformanceResult>
              <gmd:specification>
                <gmd:CI_Citation>
                  <gmd:title>
                    <gco:CharacterString>Besteksvoorwaarden en overige documentatie</gco:CharacterString>
                  </gmd:title>
                  <gmd:alternateTitle>
                    <gco:CharacterString>https://beeldmateriaal.nl/downloads</gco:CharacterString>
                  </gmd:alternateTitle>
                  <gmd:date>
                    <gmd:CI_Date>
                      <gmd:date>
                        <gco:Date>2015-07-07</gco:Date>
                      </gmd:date>
                      <gmd:dateType>
                        <gmd:CI_DateTypeCode codeListValue="publication" codeList="http://www.isotc211.org/2005/resources/codeList.xml#CI_DateTypeCode"/>
                      </gmd:dateType>
                    </gmd:CI_Date>
                  </gmd:date>
                </gmd:CI_Citation>
              </gmd:specification>
              <gmd:explanation>
                <gco:CharacterString>Data conform specificatie</gco:CharacterString>
              </gmd:explanation>
              <gmd:pass>
                <gco:Boolean>true</gco:Boolean>
              </gmd:pass>
            </gmd:DQ_ConformanceResult>
          </gmd:result>
        </gmd:DQ_DomainConsistency>
      </gmd:report

It seems that if there is a value "true" in one of the conformance declarations and also the proper citation of the implementing rule is availeble in a conformance declaration, that this is seen as INSPIRE conformant. But as youcan see in the XML sniplet, in this case the conformance value true has a relation with an other specification.

Beside this i have the impression that the calculation of DSi 1.5 is not refelcting the number of dataset metadata records with the keyword national. The numbers in NL are to high for me to check on this moment manualy, Simona or someone else have checked this more in detail.

For the download issue, i work with IE11

The anchor problems i have described in another seperate issue.

Best regards Ine

 

 

 

Also available in: Atom PDF